lenore

Regular Member
  • Content Count

    4,184
  • Joined

  • Last visited

  • Days Won

    38

Everything posted by lenore

  1. Another thought try Castrol Oil 0-30 weight European synthetic oil if you can find it. That oil is amazing how it cleans internally. Sludge is a bad thing, on the Old RX300 with 1mze engine it was a problem. That oil used to be available at Autozone, but check your local auto parts store or google Castrol oil European blend to see if you can find a distributor. Good luck
  2. I would have a leak down test done to determine what is going on with the cylinders or valves....Somebody must have never changed the oil on that puppy. Lexus engines are know to go forever and without using any oil....I have had two that used none. One at 187k miles and my present one at 161k miles. Good luck.
  3. I would also add that a once a year addition of dry graphite sprayed on a key and inserted several times is a helpful lubricant. WD is not a lubricant, it is a cleaner....
  4. Yup go for an alignment shop, these cars are generally very smooth and quiet.
  5. Yes the compact spares are there to save weight. But hey GM has even a better idea, no spare and a can of flat fix...what a stupid idea. My friend ran into this. Like you said, two hours in middle of no where and hey that big 2 inch slash and I am just sure that can of flat fixer is going to work. At least make the spare tire area big enough for full size so we can put what we want in there....
  6. They need to pull the engine and do it over....poor quality work is not acceptable. I would talk to the general manager, and see if things can be done correctly.
  7. In that case check the hose clamps....going and coming from transmission area....
  8. Could be a loose hose clamp on the transmission lines.....I would tighten them carefully and than clean everything with simple green and rinse and see where it is coming from. Another reddish color is the coolant if it has Toyota Coolant in the engine. I had a leak by the thermostat, which turned out being the intake manifold leaking cooling and dripping down the back side of the engine...
  9. You know sometimes when filling the oil it creeps down the valve over and puts drop on that pan. I filled to fast once and it went over the oil fill area before I could stop it. I would make a bottle of simple green and water and spray with a spray bottle on the front area of the valve cover and by the oil filter. than rinse very carefully just that area. After drying see if the drips reappear.
  10. Thank you so much for the feedback, You never know when this problem could happen to somebody else, and you had the solutions...
  11. Your snow tires are probably same size, but the side walls don't react the same. I would still check for wheel bearing play...but the only other thing would be suspension bushings that are aging and causing a little sag....
  12. You may have a wheel bearing going bad....maybe? Is there any wobble on the tire when you raise the vehicle on jack stands....Should be none.....
  13. I can tell you from following this issue, that the planetary gears are a weak design point on the early RX300's...The carrier was aluminum and the shaft and gears steel. However the gears would wear the shaft through the carrier causing gear wobble and failure. The replacement assembly went to a steel carrier and actually more gears....
  14. The Grills remind me of a old fashioned steam locomotive front....Really....?????
  15. Man I so do not like the Grill area.
  16. As I understand it when Toyota went to the VVTI version of the six with variable cam timing it became a interference engine. This is contrary to many parts manufacturers that were to lazy to update their info....
  17. You are so bad, but what the heck, go buy the mustang and beat it around the countryside...make sure it is a convertible.
  18. How totally true (valley girl slang) Denny....Just on a personal note when I see Ladies as well as men being given a line (bull you know what) at the dealerships or anywhere else, I stick my nose in and inform them that they are being given false or dumb down info....I find it is my duty to protect my fellow man.
  19. Would be nice also to determine which tire is low...not available on the RX400h....So you have to check all five tires....
  20. I am not able to post a link so go to Club Lexus and under the RX300 forums do a search for sun visor fix....They have a great writeup....
  21. Typical dealer garbage....Don't Toyota cars also have sunroofs? Please be aware their are generally four tubes draining water. Now if you have dirt roads and build up a lot of debris both on the bottom of the car and top this could happen.
  22. I have seen that before, corrosion in the lead eats the cable....Make sure to keep those terminals clean, and use some of those battery savers around the post. I always put a little protectant around where the cable enters the outer insulation....