Do Not Sell My Personal Information Jump to content

Heated Seats Not Working


Mr.Lextacy
 Share

Recommended Posts


just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

They may just be worn out. They don't last forever, although they do still work in my 92. Probably depends on how much the previous owner used them.

Link to comment
Share on other sites

your voltage is low , get your grounds checked as well as your battery and alternator putting out the proper voltage

that may be the case its got 144k on it still runs real smooth the only other problem is a slight jerk when i let off the gas around 35mph ? im thinking trans mount or motor mount ?

Link to comment
Share on other sites

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

They may just be worn out. They don't last forever, although they do still work in my 92. Probably depends on how much the previous owner used them.

the previous owner was a doc so im sure he used them very frequently hopefully ill get em to work

Link to comment
Share on other sites


Chances are you have an open heater circuit....meaning you will have to replace.

what do i have to replace the heater circuit ?

If the heater is burned out, Lexus will charge you 1.5 hrs per side plus parts to replace. You could try to find a repair shop to recoil the heaters for less.

Link to comment
Share on other sites

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

Have you checked to see if there is power going to the coils ? Dirty switches ? Did someone spill a coke or ?? on the switches ?

Link to comment
Share on other sites

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

Have you checked to see if there is power going to the coils ? Dirty switches ? Did someone spill a coke or ?? on the switches ?

ya im sure the doc spilled coffee on it when he had it but how do i take apart the consol my volvo was simple n i dont wna break or scratch anything

im going to try n clean it out if not i have to take it to a shop or somthing

Link to comment
Share on other sites

I have a 1995 also that i got last year with 45,000 miles and the heated seats also didn't work. It wasn't a big deal, but when it gets cold i sort of wish i had them now. Both buttons light up, but i get nothing. I do know that coffee was spilled in the car at some point, but a local shop told me the elements were burned out so i didn't think that was the problem. However, i'm not 100% convinced seeing as how the mileage is so low. I haven't done anything yet because the elements are INCREDIBLY expensive.

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

Have you checked to see if there is power going to the coils ? Dirty switches ? Did someone spill a coke or ?? on the switches ?

ya im sure the doc spilled coffee on it when he had it but how do i take apart the consol my volvo was simple n i dont wna break or scratch anything

im going to try n clean it out if not i have to take it to a shop or somthing

Link to comment
Share on other sites

Same topic on heated seats on my 95 LS 400 that I also got last week; 137K miles. The heated seat lights go on, but the heated seats don't warm up. Aside from SK, has anybody found a solution or just left their heated seats as they are. Thanks. :)

Link to comment
Share on other sites

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

I bought a 96 Lexus LS400 and the driver's seat warmer doesnt work but passenger side does. Previous owners said it would cost $1300 to repair so they never went any further with it. What would cost so much to have fixed?

I would like to have it repaired if something I get get one of my brothers or husband to do. What does everyone think exactely the problem is and how do you repair?

Link to comment
Share on other sites

just got a 95 ls4 and my heated seats dont work i checked all the fuses they seem to be fine the seat symbols light up but do not work ?

anyone had this problem

:huh:

I bought a 96 Lexus LS400 and the driver's seat warmer doesnt work but passenger side does. Previous owners said it would cost $1300 to repair so they never went any further with it. What would cost so much to have fixed?

I would like to have it repaired if something I get get one of my brothers or husband to do. What does everyone think exactely the problem is and how do you repair?

A good independant should be able to recoil the heaters for less than $250 a side.

Link to comment
Share on other sites

Ok , here is a simpler version. If you cannot provide a full 14 volts of power to the seat heater elements which is a resistor it will not warm up. You will never be able to feel if it is working until you get a high and proper voltage of 14vdc.

So you want to make sure they work get the car put on a battery charger then take the car for a drive after a min of 4 hours. It will show the heaters in action as the car has enough voltage stored to not be replenished by the alternator to run the car.

So if your battery is old , the main wires are looking corroded this adds to the resistance and makes the heater coils very ineffective.

The more voltage drains i remove from my car by new wires and LED's my seats now get hotter. It is to the point that in traffic last night it was so warm i had to open a window in 20 degree weather .

Link to comment
Share on other sites

  • 2 weeks later...

Both seat heaters seem to be inop in our '95 LS400. I have chased the circuit(s) all the way beyond the switch group and relays embedded within the switch module. I removed the rear panel on the passenger side side to get at the wiring and determined that power is getting to that point. In the repair manual they reference a 25C thermostat that is embedded in the seat cushion so it appears likely that both driver and passenger side thermostats have failed.

Has anyone ever had these thermostats replaced...?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership