lulzinking

Navigation Disk Required To Run Gps?

Recommended Posts

Hey Guys, so I bought a 04 RX330 today and promptly took it in to get detailed. Before I took it in I had played around with the GPS and Nav system, everything was fine. A few minutes after I left the detailing place I noticed my Nav System was down.

The first 3 buttons, Map, Dest and Menu simply don't respond (no beeps, nothing) but all the others are fine. After doing some digging, I decided to check up on the nav disk in the back..found where it should have been with no problems. Moved the slider, pressed the eject button..and nothing (the car was on).

Is a Nav Disk required for the system to run? Perhaps the detailing place removed it and forget to put it back..thought I don't see any reason why they would. Since I literally bought the car a few hours before getting it detailed, I have no clue if there was a Nav Disk before I went in or not...but the Nav system was working.

I tried a battery pull too, with no luck.

Anyone else had this issue?

Share this post


Link to post
Share on other sites
 

Maybe they stole your disc - go back and talk to the manager. The disc has to be inserted to use the GPS.

Share this post


Link to post
Share on other sites

Maybe the nav disc is still in there and won't eject. It would make we wonder why the previous owner got rid of the vehicle - nav problem?

Share this post


Link to post
Share on other sites

Now that you mention it, I didn't hear the eject mechanism working...could it be a blown fuse? I don't want to confront the manager of the detailing place unless I'm sure. I took a look at the fuse box in the engine compartment, but frankly there's a lot of them there and the layout doesn't seem to help narrow down which ones are for the Nav system. Anyone know which specific fuses I should take a look at?

Thanks for the help guys

Share this post


Link to post
Share on other sites

Look on the fuse box covers of the engine compartment and underdash fuse boxes for the fuse functions. Or look in your owners manual if you have one. If no owners manual, your owners manual can be viewed in the Owners section of www.lexus.com without registering.

Share this post


Link to post
Share on other sites

Thanks for bearing with me..took a look in the manual and found hte 2 that applied to the nav system, Radio 1 and 2..they both looked fine but I changed them just in case to no avail

The disk drive in the back definitely doesn't have any power to it...but since changing the fuses didn't help I'm guessing the unit is just blown.

Kind of unfortunate it happened to me the first day (was working right up until I turned it off and handed the keys to the cleaning place), never really worried that something like this might happen when getting a car detailed :\

**Update**

The system came back online all on its own! For anyone that encounters this issue in the future, I'm guessing some water damage occurred during the detailing that took down the nav system. After about 4 days of dead silence, the system just sort of resurrected itself

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By RyGuy2484
      I just purchased a 2004 GX470 about a month ago.  It has the Marc Levinson sound system with navigation, cassette radio unit with a multi-disc player in the glove box.  When you push the Audio button the nav screen, all the screen says is "Audio Off" with no audio coming from the radio.  When my lights are on at night, I noticed the radio unit itself is not illuminated which makes me believe I have a power issue possibly to the radio unit. After some research, I did come across the Service manual for the radio ( http://www.clublexus.com/forums/att...-toyota_kex-m8527-kex-m8727_servicemanual.pdf ).  
      If I put in a destination in the navigation, you can hear the audible instructions.  If you push the other buttons on the nav screen, you can hear an audible tone at the press of the button.  However, when you push the audio button, it just gives you the message "audio off".  I brought a multimeter home from work the other night to check the power coming through the wiring harnesses and from what I could tell, I am not getting any power.  (***Side note - I know enough to be dangerous but I do not claim to be a technician by any means and most of my information is from some engineering friends and YouTube...).  I referenced the various pin positions in the radio service manual to know which ones to check.  I also checked with the vehicle key turned to ACC mode and then also checked with the engine running.  Both times, it didn't appear that I had any power coming through to the radio unit.  I also checked the fuses and they all seemed to be fine.
      I called one of the local car audio shops here in town that I received a good recommendation from and he basically said good luck and they wouldn't touch it with being OEM and knowing all the issues that the Marc Levinson system has had.
      Has anyone else seen this issue?  Any ideas on where the power would actually be coming from that feeds the radio head unit?  The wire schematic is included on the service manual but it's tough to make heads or tails of it.
      Thanks in advance for any responses.
    • By sandygarf
      I have a 2014 RX 350 with 2013 maps. There is a map update screen that asks for a DVD or USB drive to update the maps.
      How can I find out what generation Nav system I have and/or what DVD I actually need.
      Please help  Thanks
    • By lexus#2
      Hi, Everyone. I just purchased a used 2015 ES300h and I need to update the navigation system map. My old HS250h required that the dealer do any nav updates, but my new car has a micro SD card slot so it looks like an update should be pretty straightforward.  Is it possible to buy the card somewhere for this GEN 8 system and install a new card myself? My local Lexus dealer is saying I have to buy a replacement card from them for $210 then pay to have it programmed. Any guidance, suggestions or options would be very much appreciated. Thank you!
    • By 04lexusrx33O
      Hello! My name is Jake and I have an 04 RX330 with 230,000 miles on it. Not certain on the history of it but I have gotten it with no heat and an overheating problem(EDIT: previous owners said it has overheated on them). I immediately knocked out the easy stuff, checked coolant levels, verified fans were working. So I end up doing serious work that it needed: waterpump, timing belt, power steering pump, upper/lower intake gaskets, thermostat(THM 117-$11.32 at napa), valve cover gaskets, spark plugs. I end up finding smoke swirling out of a crack in the radiator while the car was idling for an hour during a fuel injector decarbonizing process. I end up replacing the radiator as well as the fan motors with the relay because the fans wouldn't turn on. I ended up using a power probe straight to the old fan motors and only fan #2 worked. I end up putting it all together-bled all of the air out of the cooling system with an airlift evacuation tool-and this thing is still overheating! Today I pulled it in and put the scantool on it-temp reads 244 degrees, so it's up there. I take a laser thermometer gun and the passenger-side (or upper hose) of the radiator read 183 degrees give or take and the part of the intake that the sensor screws into was around the same. So I thought it's only a $20 sensor, and replaced it-also considering it had a previous P0117 code(engine coolant temperature circuit low input). I know when the DTC is aiming at the input part of a circuit, it's talking about something with the sensor. I thought this would do it, BUT the car still overheats via gauge. Good news was I had heat, so I'd blast it when it starts climbing up and it'd slowly go down. I'm really stumped now, because I know the heater core acts as a mini radiator, but it doesn't make sense that the heatercore cools the engine down but not the fans and radiator being fully functional. The upper heater hose is piping hot with pressure but the lower hose is room temperature with pressure, I verified by squeezing the hoses. Is the thermostat defective? I installed it with the wobbler pin positioned at the top via installation instructions. I feel like I might run a compression test tomorrow to check the head gaskets, but I feel like I'm missing another sensor or something-I'm a freshman in college so anyone with experience I'd greatly appreciate it! 
    • By matthewlswanson
      My guess would be either the first gen rx300 or the most recent gen rx350 because they have the most ground clearance. Not sure how they all compare with locking diffs, gearing, wheel articulation, low end torque, etc since I only own the first gen. 
      Second question: is the RX a lot worse off road than the LX and GX or are they close?