Search the Community

Showing results for tags 'rx330'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • New Members Introductions
  • Lexus Forum Introductions
  • Lexus Forum Community
    • General Chat
  • Lexus Owners Club - Lexus Forums
    • Lexus LS400 / Lexus LS430 / Lexus LS460 - 600h Club
    • Lexus RX300 / Lexus RX330 / Lexus RX350 / Lexus 450h / F Sport Club
    • Lexus ES250 / ES300 / ES330 / ES350 / ES300h Club
    • Lexus GS300 / GS350 / GS400 / GS450h / GS430 / GS 460 Club
    • Lexus SC300 / Lexus SC400 / Lexus SC430 Club
    • Lexus IS250 / Lexus IS300 / Lexus IS350 / F Sport Club
    • Lexus LX470 / Lexus LX450 / LX570 Club
    • Lexus GX470/ Lexus GX460 Club
    • Lexus CT200h Club
    • Lexus LFA Club
    • Lexus HS 250h Club
    • Lexus RC Owners Club / RC 350 / RC 300h & RC-F Club
    • Lexus NX300h / Lexus NX 200t Club
    • Lexus LC500 Coupe Club 
    • Lexus UX200, UX250 and UX250h Club
  • Lexus Marketplace
    • Member Buy & Sell Area
    • Lexus Owners Club Merchandise
  • Welcome to the Lexus Owners Club (USA & Canada)
  • LOC Sponsors
  • General Lexus Forums
    • General Maintenance
    • Lexus Modifications Forums
    • Audio / Video / Electronics Forums
    • Lexus Lighting
    • Wheels and Tires Forums
    • Lexus Detailing and Car Care Forum
    • Lexus Warranty Discussions
    • Dealers & Pricing Forums
    • Lexus Guides Support Topics
  • Lexus Owners Club Events
  • Lexus Misc Forums
    • Website Suggestions and Feedback

Calendars

  • Club Calendar

Categories

  • Lexus Guides
    • Lexus LS Guides
    • Lexus GS Guides
    • Lexus ES Guides
    • Lexus IS Guides
    • Lexus LX Guides
    • Lexus GX Guides
    • Lexus RX Guides
    • Lexus HS Guides
    • Lexus CT Guides
    • Lexus Detailing Guides

Categories

  • Articles

Categories

  • Videos from Lexus

Categories

  • Articles

Found 23 results

  1. Hello! My name is Jake and I have an 04 RX330 with 230,000 miles on it. Not certain on the history of it but I have gotten it with no heat and an overheating problem(EDIT: previous owners said it has overheated on them). I immediately knocked out the easy stuff, checked coolant levels, verified fans were working. So I end up doing serious work that it needed: waterpump, timing belt, power steering pump, upper/lower intake gaskets, thermostat(THM 117-$11.32 at napa), valve cover gaskets, spark plugs. I end up finding smoke swirling out of a crack in the radiator while the car was idling for an hour during a fuel injector decarbonizing process. I end up replacing the radiator as well as the fan motors with the relay because the fans wouldn't turn on. I ended up using a power probe straight to the old fan motors and only fan #2 worked. I end up putting it all together-bled all of the air out of the cooling system with an airlift evacuation tool-and this thing is still overheating! Today I pulled it in and put the scantool on it-temp reads 244 degrees, so it's up there. I take a laser thermometer gun and the passenger-side (or upper hose) of the radiator read 183 degrees give or take and the part of the intake that the sensor screws into was around the same. So I thought it's only a $20 sensor, and replaced it-also considering it had a previous P0117 code(engine coolant temperature circuit low input). I know when the DTC is aiming at the input part of a circuit, it's talking about something with the sensor. I thought this would do it, BUT the car still overheats via gauge. Good news was I had heat, so I'd blast it when it starts climbing up and it'd slowly go down. I'm really stumped now, because I know the heater core acts as a mini radiator, but it doesn't make sense that the heatercore cools the engine down but not the fans and radiator being fully functional. The upper heater hose is piping hot with pressure but the lower hose is room temperature with pressure, I verified by squeezing the hoses. Is the thermostat defective? I installed it with the wobbler pin positioned at the top via installation instructions. I feel like I might run a compression test tomorrow to check the head gaskets, but I feel like I'm missing another sensor or something-I'm a freshman in college so anyone with experience I'd greatly appreciate it!
  2. My guess would be either the first gen rx300 or the most recent gen rx350 because they have the most ground clearance. Not sure how they all compare with locking diffs, gearing, wheel articulation, low end torque, etc since I only own the first gen. Second question: is the RX a lot worse off road than the LX and GX or are they close?
  3. I have a 2004 RX330 which has a 6 CD changer and a cassette player. Has anyone had any success installing an adapter such as this one to allow direct mp3 input? I have a FM radio transmitter, but the reception from my phone from the headphone jack through the transmitter is spotty and has static. I don't want to use bluetooth. I'm having the dash replaced by the dealer so I thought this would be a good time to do this. Thanks for any guidance/suggestions. Bob http://pac-audio.com/productDetails.aspx?ProductId=1082&CategoryID=45
  4. 2006 RX330 210,000 km runs fine. NOT powered open or close kind, very basic liftgate strut style with a open switch on it.Failing Lock actuator symptom: Liftgate locker stuck close sometimes after press release button[switch], very weak or slow click from lock actuator motor, most of time the locking system may work after the first press,but second and third press within short time almost impossible get locker release. same pattern will happen after lock and unlock the car couple minutes later.I guess the thermistor [kind of motor overheat protection] inside the motor is shot, so a motor replacement worth a try as it is dirty cheaper than a actuator assembly.After replace the motor only, now the liftgate lock release works very well with strong motor running sound even continue press unlock switch.Start from both side and pull hard. Old vs new Most Google search info are door lock actuator motor repair,so I order this D flat shaft as it will compatible both round shaft and D flat shaft. This is exact right replacement motor w/ brass collar Small but handy tool! Below are two used items on ebay listing which show fit for 04-09 RX330/RX350,but it appear quite different design.may fit for power open and close liftgate version.
  5. Rx330

    Hello everyone I'm Ausencio aka (chingy) I just bought a 2004 rx330 I liked the car then a couple days later I wanted the is250 I like the rx but then everyone started saying it looks like a girls car and it stayed with me!
  6. The topic name is self explanatory, Passengers side HID light is dead, replaced the bulb (D2S) with a new one, still dead, checked the old bulb in the drivers side light fixture, works fine, so the problem is not with the bulb. Checked the connections, look clean and good. What else could it be. Thank you. P.S. Dont want to go to my mechanic if it is something I can fix on my own.
  7. Tires for RX330

    Looking for recommendations for all season tires for 2004 RX 330 - the current size is 235/55/18. After doing some research I was leaning towards Michelin Premier A/S or Bridgestone H/L Alenza Plus. My local tire store is recommending that I consider Cooper or Nokian and said to stay away from Michelin and Bridgestone. Any help would be appreciated!
  8. My wife's Rx330 has about 150k miles and recently started failing in various places. First the starter gave up and stopped engaging. Replaced it, but after a little while a 2.5 year old battery also failed. Replaced it as well but decided to check up an alternator. It also failed the test, was generating about 13.3v output. So I'm going to take it out today and replaced it as well. The question I have is the following, what could have caused such a massive failure? I understand that bad alternator could cause the battery to go bad and vice verse but why the starter then? Could there be some underlying other problem? Also after I replaced the battery, the windows in the back and front passenger side stopped opening from the drivers console, but are opening from each door controls. Thank you
  9. Within the past year, my 2006, rx330 started to emit a tweeting sound when the key is inserted in the ignition and it is turned to start the car. It was rare at first, now it is on almost every startup. It lasts until the motor kicks in. Other than that the car runs very well. Anyone know what it is?
  10. Greetings Folks: Over a week ago we brought our ’06 RX330 in for service to replace a fitting on the engine that had been leaking coolant, eventually causing overheating. We got it back a day later, and it ran fine. However, this past Tuesday, the CEL (Check Engine Light), VSC and TRAC OFF lights came on, all at the same time, and have remained lit since. I dug on the internet to find some solutions and/or troubleshooting, and was met with quite a bit of information. However, I wanted to ask any RX330 owners here if they have experienced the same thing. In the meantime, I took the following troubleshooting steps: I checked the fuel cap to make sure it wasn’t loose. As a further safeguard, I bought a new one ($15) and put it on. CEL remained on, as did the VSC and TRAC OFF. I went to Pep Boys to have them scan and pull a code. It read P0420: (Catalyst System Efficiency Below Threshold (Bank 1)). Now, this same site lists a whole series of tests to perform before heading out and laying down some $$$ for a new cat. So I’ve decided to go through a few of them: I took the car for a test drive and listened for any inconsistencies and/or rough idling, etc. I found none, and engine was running smoothly between 1-2K RPM as usual. I bought some fuel injection cleaner, fuel cleaner, and a can of MAF Sensor cleaner just in case. Right now I’m at a little under half a tank of 87 gas, so I’m going to wait until it’s under a quarter tank and pour in a bottle of the fuel cleaner or CataClean and see what happens. Today I’m going to check the air filter and possibly the spark plugs if I have time, to see if they’re all mucked up. I guess that’s the best time to clean the MAF sensor as well. So, that’s my process so far. Is there anything else I should take a look at? I’ve heard about checking and/or replacing O2 sensors but not sure if that’s really the issue here, but would love to hear your input. Thanks for listening, and would love to hear your feedback.
  11. This morning both by check engine and VSC lights came on. I took the car to Autozone and the tester said that P0420 code appeared twice. He sold me a bottle of Cataclean and told me to try that first. Any chance that will work? Should I reset the lights after using Cataclean or should it go off on its own? How do I reset the lights (remove power to the battery for a few hours or is there an easier way)? Am I safe driving the car around in the meantime? Any other suggestions? Anything else it could be or is that code pretty definitive as to what the issue is? Thanks in advance!
  12. I hit a deer in my beige 2006 RX330. Surprisingly, the only damage I had was a broken off right front bumper hole cover, and a bent license plate frame. Finding that bumper part in my car's color is incredibly difficult. The local dealer wants $18 for the part, and another $70 to paint it. We're talking a 2"x2" snap-in plastic piece. For that price, it should be hanging on a wall in a museum! Can anyone recommend a good salvage parts website to check where I might be able to buy a used one in my color? There have to be dozens of my exact car being parted out yet after hours of searching on the Internet, I haven't turned up any with this part available in beige. Thanks!
  13. I was wondering if anyone could give advice on removing an alternator for a 2004 RX330. 1) Specifically, once unbolted, does it come out from the top (and if so, what needs to be removed first?) or does the front passenger wheel need to be removed in order to jiggle it out from underneath the car, etc.? 2) What is the easiest and/or proper way to do it? 3) Also, once it's removed, is it recommended to replace any belts (if so, which one(s)?). 4) Any other maintenance to do while it's off? We had to bring it in to a Lexus certified repair shop to have some work done on it a couple of years ago and I seem to remember replacing at least one of the belts then but can't remember which one(s). Mileage is around 202,000. It's been a while since we've had to replace an alternator (last one was on the ES300 I had prior to the RX330). Thanks in advance!
  14. So a few years ago, my mom gave me her 2005 RX330. It's always been garage kept and still looks new. It's got 95k miles on it and until now has never had a problem. I recently noticed the steering wheel was making a funny noise and turns out I've got a power steering leak...it needs a new rack and pinion, a $1,000 fix. I told my parents about it and my dad made me an unexpected offer. My parents are retiring and going from 4 vehicles to 2. He said if I didn't want to shell out the money for the repair, he would trade his car for mine: a 2013 Toyota Avalon, and he would sell my RX. So the Avalon is 8 years newer than the RX. However, it has 83k miles already from weekly out-of-state business commutes. But aside from the high mileage, it's in great shape and never had any problems. I'm really torn. Both are very sharp looking cars, both black on black. I've always loved my Lexus and at first couldn't imagine parting with it. But last weekend I drove the Avalon quite a bit and have to admit it definitely is more fun to drive. It also obviously has updated technology. But it's not quite as comfortable as the RX. Does the added status of the Lexus being a luxury car compared to the Toyota kind of become moot given it's 10 years old? The fact they're both roughly the same mileage is what's really throwing me for a loop. I'm trying to figure out 7-10 years from now which car would have been the smartest choice. And i'm really stumped. I would appreciate any advice. Which car would you choose and why?
  15. Hi, I need to change my struts and can't decide whether to use OEM or use KYB or Monroe. Has anyone here used KYB or Monroe? If yes, how did they compare to ride equality of OEM struts? Thanks!
  16. Yesterday morning when I moved my RX330 it was making a loud grinding sound coming from somewhere under the vehicle near the rear. After driving down the street for about a block, a chunk of ice fell off the rear driveshaft. It was about 1" thick and it had formed completely around the driveshaft - meaning that it must have accumulated while I was driving the night before. I've never heard of this happening before. Have any of you heard of it or experienced it? Any theories about how so much ice could form around a moving driveshaft? Should I be concerned about it happening again?
  17. I have a 2004 Lexus RX330 which has a Mark Levinson sound system. The problem is that the front two speakers sound like they are blown especially the right front one. So I was thinking about replacing the speakers myself instead of taking it to Lexus and paying them $700.00 for one speaker lol. Would anyone be able to tell me the ohms and everything for those front speakers? I was told that I need to have speakers with the same Ohms and Ampers so I don't run the risk of blowing the amp. Thanks!! And any help would be appreciated!
  18. I have an '04 RX330 that seems to have something in common with 75% of the RX 330s on the road today. The passenger side mirror is discolored with an amber fluid. Yes I know what it is. Somewhere the seal was broken and the fluid which is used to defrost the mirror is either leaking or has been compromised. The local dealer would like to charge me $585 for a new piece of glass. Thank you... no thank you. My question is, why has Lexus not recognized this as a systemic problem with this vehicle. Seriously 3 out of 4 RX330s you drive by have this problem with the passenger side mirror. How many vehicle need to have this problem before a recall is issued or considered? I called Lexus and was advised that they have no advisory or memos of this as a problem. I hope that call "was recorded for quality assurance purposes." How many folks have this problem? Speak up... Have you had any success with getting Lexus or the dealer to fix this problem at a cost less than highway robbery?
  19. Hey All, Basically I have a the stock 8 speaker JBL/Pioneer system (no nav. no mark levinson) and I would like to know what frequency signal goes to which speaker set from the stock amplifier. I was told that the back door and dash have full range, but that there is a crossover in the amp that restricts the front door to mid-low range. Thanks in advance!
  20. Hey Guys, so I bought a 04 RX330 today and promptly took it in to get detailed. Before I took it in I had played around with the GPS and Nav system, everything was fine. A few minutes after I left the detailing place I noticed my Nav System was down. The first 3 buttons, Map, Dest and Menu simply don't respond (no beeps, nothing) but all the others are fine. After doing some digging, I decided to check up on the nav disk in the back..found where it should have been with no problems. Moved the slider, pressed the eject button..and nothing (the car was on). Is a Nav Disk required for the system to run? Perhaps the detailing place removed it and forget to put it back..thought I don't see any reason why they would. Since I literally bought the car a few hours before getting it detailed, I have no clue if there was a Nav Disk before I went in or not...but the Nav system was working. I tried a battery pull too, with no luck. Anyone else had this issue?
  21. Hi everyone! I just wanted to share my iPad Mini Sound System install in my Rx330. Take a look and let me know what you think. I have other demos as well, check them out here: https://www.youtube.com/playlist?list=PLm0HbnjEFcuWreTXdbqGiLFQz3n-78uNM I look forward to feedback and any ideas of cool apps for in-car use. Thanks!
  22. Anyone have WeatherTech All-Weather Floor Mats (part number: W40) in their 2006 RX330? These are NOT the FloorLiner DigitalFit product. I would like to know how they fit. Are they the exact fit to the 2006 RX330? http://www.weathertech.com/lexus/2006/rx/floor-mats-all-weather/
  23. Sound Upgrade Choices...

    Hi I have a 05 RX330 I had the JVC kw nt30hd navigation head unit installed with the beat sonic amp integration. It sounds better. But now I bought two Polk audio DXI series 6.5 components as well as two 6/9s. And a Kicker 4channel amp. We are going to let the head unit power the dash speakers and the other six(tweeters included) on amp. My question is has anyone upgraded all the factory speakers with an amp and if so was the sound better? And if so how much better would you say..? The factory speakers sound great currently with the new stereo so I was wondering what to expect. Thanks!