Do Not Sell My Personal Information Jump to content

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Similar Content

    • By Dylan Schultz
      i have a 98 ls400 with about 244,000 miles on it. I’m having this very odd issue with the car. When I come to a stop light/ sign, the battery light comes on, rpms drop straight to 0 and the engine dies. Air and radio some times stay on. If I put it in park and restart the car the light goes away then its fine to drive until.. ya guest it I come to another stop. It does the exact same thing over an over at each complete stop. I assumed it was the alternator and I replaced it yesterday. No battery light, or weird idols happened for about a day. it is back to doing the battery light thing. If anyone has any Ideas of what it could be, or how to fix this issue id really appreciate it. ALSO not sure how old my battery is, changed the negative battery terminal when I did the alternator. Positive could be the problem (Corrosion on positive terminal) or maybe the terminal cable(s)?? Im very new to working on cars and any information is appreciated and retained. 
    • By Alex.VVV
      At about 2am at night my car starting randomly ticking. It wasn't running or anything. After I unlocked it to try and start it, it started making the same ticking noise and wouldn't start. When I turned off the ignition the noise started again. It was coming from around the bottom of the firewall, between the engine and transmission. I touched the battery and it was awefully warm so I took off the positive terminal and it stopped. I would guess it's the starter but I don't know why it would do that so randomly.
      Edit: it did the same thing about 15 minutes ago, but this time the lights were flashing and siren went off. Can it be the antitheft?
      Here's how it sounds. With ignition and keys out.
       

      IMG_5488.3gp
    • By GsJoe300
      Can someone please help me! I got my ignition coil changed on my 2004 gs300 on saturday because my car was having misfires. After changing the ignition coils I tried to crank the car but it wouldn't start, we disconnected everything new and put all the old ones back on and still nothing, then I realized the alarm indicator is blinking even when the key I in the ignition and turned. I tried a locksmith and he assured me nothing is wrong with the key, PLEASE HELP ME. I've changed the fuel pump, spark plugs and also tried everything I read online about resetting the alarm and nothing works, I can activate and deactivate the alarm from my key pad but the light continues to blink and the car refuses to start
    • By CorrosiveSmoke
      I have a 2000 lexus es300 at 136000miles in park or neutral I can rev the car up just fine but when I put it into gear the rpm barely creeps along even with my food to the floor, it gets a little bit better after the car is warmed up but not by much It still takes a minute for it to wind up enough rpm to start accelerating, I know it needs a couple knock sensors. I'm running some Chevron Techron Fuel System Cleaner through it now. any advice could it be the evap canister or pcv?
    • By BeachBumForever
      Need help locating PCV valve on my 2003 ES300. Photos will be helpful since I want to install a new PCV valve on the car. Any suggestions on parts and removal/install will be appreciated.
×
×
  • Create New...