Sign in to follow this  
gunni

Need Some Advise Asap

Recommended Posts

Hi guys/girls...

I have a BAD problem with my 02 IS300.. :wacko: The thing is that the car started some weeks ago to shut off the engine while driving and wont start again to run, from 2-3 minutes up to 20 minutes..Sometime the engine starts but when the throttle is advanced the engine kills again...some times its seems to work if you have full throttle and then put it instanlly to D(drive)

then mabye some miles but most often the engine goes off when slowing down and stopping at the traffic lights.....I have a Injen air intake wich is aftermarket...The car runs when i disconnect the IAT sensor but it has to be started twice and it wont go over 3000 rpm...I have been to the Dealership for diagnostic and the said the this must have been IAT sensor with a fault, so I bought a new one ok.....IT changed nothing...then the Dealer said its the O2 sensors, ok so the got replaced...The car ran smooth and normal for 6days but then started to behave like described....The dealer guys says the only thing they get from the diagnostic is the IAT sensor code and that is because its the INJEN air intake...but the sensor is new..SO THEY HAVE NO IDEA WHAT TO DO....The car was at the dealership for 4 weeks with no results.........MY question to all of you is Can you give me some advise what it is that is troubeling my car..

ALL HELP AND ADVISE IS VERY APPRECIATED :cheers:

thanks

Share this post


Link to post
Share on other sites

Put the stock intake back on and see if the problem goes away. Sometimes the engine cooling fans cause turbulent air that messes up the air flow sensor when you have one of those big cone filters inside the engine bay. This most often happens when coasting to a stop or while stopped and idling. Aftermarket intakes can also cause a false signal from the air flow sensor due to having to relocate the sensor on the intake. While you're at it, get some electronics spray cleaner and clean the air flow sensor too.

Share this post


Link to post
Share on other sites

Ok. Do you think there is available some "dummie" for the sensor..recall that sometime people had to do something like that to get the check engine light out ?? THink this is somewere avai ???

Share this post


Link to post
Share on other sites

I don't know of any dummie for the MAF. If the MAF Isn't getting a proper reading the motor just isn't going to get the right signal to adjust the fuel/air mixture. The point about the turbulence from the fans is that the throttle body really is getting poor airflow and that's why it can stall.

There are Sims for the Oxygen sensors in the exhaust though. Sometimes those are needed to get around CEL's from Headers or exhausts that eliminate any cats.

Share this post


Link to post
Share on other sites

and IS it possible if the MAF sensor is given wrong signal can the engine die ? even though the throttle pos is variable ?

Share this post


Link to post
Share on other sites

How long have you had the cold air intake on it? And what kind of filter are you using? Did they happen to tell you what code is coming up? I'm wondering if it's your knock sensor.

The knock sensor located on the cylinder block detects spark knock. When spark knock occurs, the sensor pick up vibrates in a specific frequency range .When the ECM detects the voltage in this frequency range, it retards the ignition timing to suppress the spark knock. The ECM also senses backgraound engine noise with the knock sensor and uses this noise to check for faults in the sensor. If the sensor signal level is too low for 10 seconds, and the knock sensor output voltage is out of normal range, the ECM interprets this as a fault and sets a DTC.

Share this post


Link to post
Share on other sites

The Intake has been installed for 19 months now. And about the Error code they didnt gave it to me..

Is it a major problem replaceing the knock sensor ?

I am waiting to get the stock AIR intake since it didnt came with the car when i bought it. Looking for used one if anybody know about one :)

Gunni

Share this post


Link to post
Share on other sites

Where in Florida are you?

Share this post


Link to post
Share on other sites

I am actually in Iceland...I have only a vacation home in Florida...So I would need the item sent to me overseas..Tell me if you can help me on this..

Thanks

Gunnar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this