Jump to content


JDM UCF21 “Engine Main” relay missing?


Fi7e

Recommended Posts

Just checking to see if this is normal. Figured my car either wouldn’t run or have CEL’s on if it wasn’t.

 

 

IMG_0130.jpeg

Link to comment
Share on other sites


Do you have access to the wiring diagram? I agree that it is likely that the fuse should be there.

Link to comment
Share on other sites

You have a Celsior so it may be normal.  It's not normal on a NA LS.  My '98 has a relay in that position.  Here is the circuit that contains the Engine Main Relay:

Untitled_29a.thumb.jpg.23ae17b5dce644c884d8934bb65e44af.jpg

From factory 1998 Lexus LS400 Electrical Wiring Diagrams

Double-click the image so you can see it.  Essentially, the relay powers the electric cooling fan and the front seat heater (if equipped).  This relay doesn't appear to run thru any of the many ECU's that an LS has.  That's why you won't see any trouble codes.

A previous owner probably removed the relay as an expedient to taking the time to troubleshoot whatever the issue it was causing.

Quick check: Does the cooling fan come on?  If you have heated seats, do they warm?

Link to comment
Share on other sites

12 hours ago, paulo57509 said:

You have a Celsior so it may be normal.  It's not normal on a NA LS.  My '98 has a relay in that position.  Here is the circuit that contains the Engine Main Relay:

Untitled_29a.thumb.jpg.23ae17b5dce644c884d8934bb65e44af.jpg

From factory 1998 Lexus LS400 Electrical Wiring Diagrams

Double-click the image so you can see it.  Essentially, the relay powers the electric cooling fan and the front seat heater (if equipped).  This relay doesn't appear to run thru any of the many ECU's that an LS has.  That's why you won't see any trouble codes.

A previous owner probably removed the relay as an expedient to taking the time to troubleshoot whatever the issue it was causing.

Quick check: Does the cooling fan come on?  If you have heated seats, do they warm?

Interesting, thank you. My fan does turn on, I just checked that 2 days ago and I do not have heated seats…

Link to comment
Share on other sites

I didn’t do anything to resolve the “problem”. My Celsior doesn’t need that relay. My fan is hydraulic and I don’t have heated seats.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Forums


News


Membership