Do Not Sell My Personal Information Jump to content

Finally I Can Post My Questions!


Recommended Posts

Ok so i am new to this and i have a few questions that are really bugging me. i am really excited to have this forum to be able to post too and look to for answers. thanks for that BUT i am having a few problems with my 95 sc 300.

FIRST:i have read all of the posts about fog lights not being main lights on models older than a certain year but mine is a 95 and and when i got the car about 5 months ago my fog lights worked, now they do not work, i have checked the fuse and its all good. it could be the bulbs but would they go out at the same time?.....and so i am a litte unsure but i think i read that there is some kind of switch that may have been turned off during maintenance. i just recently got my alternator replaced and the guy that did it does great work but is also great at not putting thigs back like he found them.lol hint hint maybe he unplugged something...anyway please please tell me all available knowledge on that. thanks

SECOND: i was wondering if there was any difference in the older sc300 motors and the newer model sc3's as far as liter wise and hp. someone told me the older ones were better.thanks

THIRD: i am in no way a racer.lol but to tell you the truth one day some guy told me he thought sc300 stood for supercharged 300.lolololol :chairshot: so that is one reason why alot of people try and race me, i am a girl also so they think that im just gunne sit back and watch them run over my sc. not happenin anyways the point is, when i get on it a little bit up around 60, my car shakes and gets really loud and rumbly. its not a bad sound so i dont know if its supposed to do that? please help so i dont blow up my car. and also it redlines really fast. thank you for any answers.....i have been waiting to get varification to post anxiously....lol

Link to post
Share on other sites

I am desperatly needing help with the fog light part of my post anyone who knows please let me know. i am wanting to replace stock headlights with silverstar ones and am wanting to get the fog lights working where i can add the silverstars to them too.thanks

Link to post
Share on other sites

i have an sc3, I would first check one of the fog light bulb to see if it has actually burned out. If both are burned out that would be strange, but you never know until you check.

"fog lights worked, now they do not work, i have checked the fuse and its all good. it could be the bulbs but would they go out at the same time?"

Link to post
Share on other sites

Thank you so much for replying i posted that question and havent gotten any help. i actually pulled out the bulb but i cannot tell if its burned out. and also i was told i cannot get the bulbs at a regular part store like autozone, do you know anything abou that? thanks again as no one around where i live has a car like mine much less knows anything about them, when i went to my autozone the guy asked me if it was the 4 cyl. and i said no 6 and he sai lexus only makes 4 cyl. so there ya go.lol thats why i was waiting on someone to reply. ;)

Link to post
Share on other sites

sorry to hear about your autozone situation, i guess the associate there doesn't get out much... either that or someone should check to see if he's been sniffing the throttle body cleaner...

Info on your car..

http://en.wikipedia.org/wiki/Lexus_SC300

I always thought SC stood for sports coupe or something like that..

Your foglight bulb should be a H3 type bulb which you can buy anywhere. Are you 100% positive you checked the correct fuse?

As far as the shaking goes... could be your tires need to be balanced.. could be shocks.. could be something much worse...

I can't tell you anything about the noise, many cars use the 2JZ-GE engine and they're on the quiet side when left stock. Maybe you have a hole in your exhaust somewhere?

When it comes to your mechanic... I'd try to find another one... not the kind of absent mindedness you'd want in someone who puts the brake pads on your car...

Link to post
Share on other sites

Thank you so much for replying i posted that question and havent gotten any help. i actually pulled out the bulb but i cannot tell if its burned out. and also i was told i cannot get the bulbs at a regular part store like autozone, do you know anything abou that? thanks again as no one around where i live has a car like mine much less knows anything about them, when i went to my autozone the guy asked me if it was the 4 cyl. and i said no 6 and he sai lexus only makes 4 cyl. so there ya go.lol thats why i was waiting on someone to reply. ;)

'i have an sc3', I thinking you are mistaking the parklight bulb (168/198 part #) for the fog light bulb, here is a picture below of the parklight bulb, is this the bulb you took out of your Sc300?

post-1539-1175183401_thumb.jpg

Link to post
Share on other sites

thnk you for the link. uhm, i had my boyfriends dad whoes been a mechanic for 34 years check the fuse and he said it was good. so i got underneath there and thought they might have been unplugged but they werent so i said ok well they must be bad and th bulb was attached to a little metal plate which was attached to the cluster, but if you think i should be able to get them anywhere than ill try but y bfs dad said id have to go to lexus and he works at advanced autoparts and he said they dont carry them. i am so confused.

Thank you so much for replying i posted that question and havent gotten any help. i actually pulled out the bulb but i cannot tell if its burned out. and also i was told i cannot get the bulbs at a regular part store like autozone, do you know anything abou that? thanks again as no one around where i live has a car like mine much less knows anything about them, when i went to my autozone the guy asked me if it was the 4 cyl. and i said no 6 and he sai lexus only makes 4 cyl. so there ya go.lol thats why i was waiting on someone to reply. ;)

'i have an sc3', I thinking you are mistaking the parklight bulb (168/198 part #) for the fog light bulb, here is a picture below of the parklight bulb, is this the bulb you took out of your Sc300?

yes it looks like that, not blue but white and its the light farthest down to the ground. not the orange ones on the side but the sorta wierd shaped ones at the bottom. almost triangular.i couldnt get the bulb out thats why i thought it must be the whole cluster.

Link to post
Share on other sites

'i have an sc3', I thinking you are mistaking the parklight bulb (168/198 part #) for the fog light bulb, here is a picture below of the parklight bulb, is this the bulb you took out of your Sc300?

yes it looks like that, not blue but white and its the light farthest down to the ground. not the orange ones on the side but the sorta wierd shaped ones at the bottom. almost triangular.i couldnt get the bulb out thats why i thought it must be the whole cluster.

'i have an sc3', How do you know what the foglight bulb looks like, if you can't get it out? The foglight bulb is held in by a clasp and this acts like the ground wire. Inorder to open this clasp to remove the bulb you need to push down and it will open and the bulb will come out of the compartment.

Link to post
Share on other sites
  • 2 weeks later...

Hey there...I hope you finally got your fog light issue resolved. I had a similar issue when one of my bulbs blew out. I thought at first it was going to be simple to just replace the bulb. But unfortunately, it is not a simple excercise. I first had to jack the car up and then remove these plastic covers located under the fenders in order to gain access to the back of the fog light assembly. Once I did that it was a simple matter of removing the clasps that hold the bulbs in place.

I actually went to Pep Boys and bought a new pair. Hyper White I believe. You must definately remember that when replacing the bulbs make sure that they are grounded properly or they will not work. After I replaced the bulbs the one on the passenger side still did not work; however, once I got back under the car I had to make sure the bulb was seated in the socket correctly and that it was grounded. Now it works great..

Hope all is well...

Jitters

Link to post
Share on other sites
  • 4 weeks later...

hay, thank you to all of you tht helped me with my fog lights, i replaced them and now they work so i guess they really did go out at the same time, anyway now my problem is that they are burning waaaaaay too hot and it is melting my plastic, the outside of the actual foglight. i saw something on it today and went to rub it off with my finger and i actually screamed cause of how hot it was so i know just from common sence that fog lights should not make the plastic THAT hot so now i am gunna have to go back underneath there and figure out whats causing that.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...