AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




Flashjett

New Member From Texas, Flashjett

Recommended Posts

Flashjett    0

1997 SC400

I had a lot of chips in front from highway driving and used Plasti-Dip to spray on what looks like a protective black bra.  I thought it turned out very nice.  At 6 bucks a can and only two cans used, this was way cheaper than trying to match the green body paint and looks better too.  And if it didn't turn out, you can just peel off the Plasti-Dip.  Fun stuff.  The bra turned out so well that I then did the wheels with green.  Been driving with the bra for almost a year and it is doing great to protect from gravel chips from highway driving.

The electric windows just quit working.  Moon roof is working fine.  Not sure what to do from here. Any words of wisdom?

Front Bra.jpg

Green Wheels.jpg

Back SC 400.jpg

Share this post


Link to post
Share on other sites
 
Trevor Catt    24

Hi Rob....welcome to the Forum

Great looking SC...absolutely looks the business!

Good to have you onboard

Cheers,   Trevor

Share this post


Link to post
Share on other sites
lenore    60

Sweet ride, welcome aboard.  I just bought a Toyota Solara convertible, I see so much resemblance.  

Share this post


Link to post
Share on other sites

  • Similar Content

    • By The"jasmine"SC400
      Hey guys, I just bought my first sc400 and I have a couple questions, my biggest concern is that she keeps burning alternators i read somewhere that it might be my power steering? Or someone mentioned the valve cover cap? Any help would be greatly appreciated as i cant afford to take her to a shop, also any general tips about this car Would be awesome, thanks guys!
    • By Poughboy
      Ok, question for you guys. I have a 93 sc400, bunch of little ussues. But my alternator went outo. So I changed the alternator out. Now my rpm gauge doesn't work. It may start working tomorrow.  Does it have its own sensor or is it the cam sensors? We know it's not the distributor. Any help would be great and thank you in advance
    • By ElijahxF
      so i'm in an epiphany. my Lexus sometimes will start and sometimes wont start. had it running 2 days ago but in order to start it i have to disconnect the EFI Main relay under the hood  wait a couple seconds then jump the b+ and the Fp things under the diagnostics port inside the engine bay.   engine cranks really fast (not used to cars cranking that fast maybe) just doesn't get any fuel. when you have the key on the on position and you jump the wires you can hear fuel going into the engine. what do you guys think that could be? Fuel Ecu, cold start injector?  any help would be much appreciated. thanks! 
    • By kenzotic
      Hello there, I'm new to this site but figured it would be a good place to get some advice. Okay, so I found a 1992 Lexus SC400 with 156k original miles on craigslist for $3500, clean title. I've been doing my research on these cars for awhile and this is the first I've actually found close to where I live. So I went to the guy's house earlier today to check it out and it seems really nice. It seems to have been decently taken care of, has originally red paint that has no clear coat peeling and only a couple tiny dings in the body. Also has moisture in the driver's side headlight but not a big deal at all. Overall I'd give the exterior about an 8/10. Interior is also really nice, only a few small tears in the driver's side seat, broken door handle, and a few of the gauge cluster needles are blacked out, I've heard this is common on these cars. Car also has a new exhaust system on it that is quiet at low rpms, but comes alive at higher rpms, which is perfect in my opinion. So besides what I've already listed, the only other flaws are that it could use new tires soon, the left-hand turn signal bulb needs to be replaced, and the brakes felt a little spongy, probably just from the brakes needing to be bled. Luckily, the dude said he would give it to me for $3k. So, is $3000 for this car a good deal? Any problems I should watch out for with this mileage? Any insight is much appreciated, and feel free to ask questions, I'll answer what I know! I'll upload what pictures I have of it c:








    • By pqmccracken
      New here, and joined to ask this so yes i have googled and i have searched, just maybe not in the right way. Is there anyway to reach wiring ports to the starter without taking the intake off? My first 1uz ive owned and im fairly confident that the wiring to the starter is loose. Hoping there is a better solution than taking the manifold off to reach the starter. Thanks.