Do Not Sell My Personal Information Jump to content

VMF

Super Moderator
  • Content Count

    2,079
  • Joined

  • Last visited

Community Reputation

0 Neutral

About VMF

  • Rank
    Guru Member
  • Birthday 06/21/1978

Contact Methods

  • AIM
    vital4ik
  • ICQ
    29957010
  • First Name
    Vit

Profile Information

  • Gender
    Male
  • Lexus Model
    1996 LS 400
  • Lexus Year
    1996
  • Location
    New York (NY)
  1. yes, the HQ said that 2004 model year had the issue with soldering and overall position of the wiring in the head unit. it has been resolved in the 2005 year but 2004 owners are stuck. new head unit was around 5k. so traded in the car back in 2013 for a new GS 350, which eventually experienced the same issue with its head unit dying if the car is parked in the sun for few hours:) that got replaced under warranty.
  2. turns out i have spare set of pads, and this is what i have found so far for PNs: rotor front right: 43512-30350 rotor front left: 43516-30040 shim kit: 04946-30210 any1 did this before?
  3. Hi crew! Cant seem to find the right info to get these online. Anyone knows proper part numbers for rotors, shims and brake pads for a regular 2013 GS350 AWD?
  4. Hi guys, its been a while!:) I am looking for all required part numbers/parts list to change rotors and pads on the 2013 GS 350 AWD. my rear rotors seem to be rusted to the point where i cant drive the car. Car has been standing for quite some time and i guess that did it. I remember when i did this on my old 96 LS I had to also buy some other parts to put on pads, forgot what they are called.
  5. thanks man,you are correct! ive been reading and the problem is in the connection where the plug is connected to pcb in 2004 models . im gonna try to fix it myself first or get an 05-07 board/screen. dcfish has some for sale?
  6. good day guys! recently our 04 ls430 with navi starting to experience blackouts when screen would black out, navigation, climate control and some audio controls will go blank, along with driver/passenger small temperature screens. pressing navi button will produce "the external system is not connected" message on the screen and pressing climate button will produce "check connection of the air conditioner" anyone had this issue before? is it just a connection issue or something is wrong with the touchscreen module?
  7. its a known issue on the early Ls, mine did the same thing, from what i was able to find out talking to one of the lexus tech ppl, is that it is a software issue but since it doesnt really cause any issues they never bothered to fix it
  8. i bought mine with 107K miles on it and the rule of thumb is to let it be. from my previous experiences, if the tranny fluid is not changed within certain periods of time and then you change it at 100k, tranny dies. so i let mine be, sold the car with 180k miles and it is going strong still. my advice, dont touch it or you can open a whole new can of worms
  9. in a very good condition $225 shipped for all 3 in US.
  10. hey guys, im thinking of moving from the 17 inch oem rims to the bigger ones, possibly oem 18 inch ones. does any1 know the offset and tire size for the 18 inch rim?
  11. make sure you have all the thins you need, harness, adapters etc. then this job is a piece of cake
  12. early LS had an issue with PS pump leaking on the alternator and eventually destroying them.but whining usually is due to the clogged filter or due to the air in the system. what i usually do is i dont even bother bleeding, i just leave the cap on the reseroir open overnight and that takes care of the air in the system:)
  13. here is a lil tutorial ive done when i was changing mine few years ago:) http://www.lextreme.com/timing.htm now its almost time for another change:)
  14. no smell insiide? check the passenger side carpet, see if its wet, it might b the heater core.
×
×
  • Create New...