Do Not Sell My Personal Information Jump to content

Cruise Control Stopped Working


Recommended Posts

So my cruise control engaged and started to accelerate the car and then instantly let off and stopped working. That was 3 days ago and I try it every time I get in the car and it doesn't work. I looked up on here how to check it and the first thing the forum says along with the manual is that the cruise control light will flash 5 times then shut off to show there is an error.

WELL THAT IS MY PROBLEM: The cruise control light never flashes. It stays on and acts like everything is fine and working properly. I am very mechanical but don't know where to start to track down this problem now that the cruise control itself doesn't think anything is wrong. Anyone have the factory service manual and could post how to track down this problem? My car is a 1998 ES300.

J. R.

Link to post
Share on other sites

Check the brake switch, if that is has loosened up and moved cruise control will not engage. Since the cc was designed to dis-engage when the brakes are pressed, it will generate no error codes.

That is a good idea. If that was the case though my brake lights would be on all the time correct? So I can check that switch, but also rule out that being the problem if my brake lights aren't on all the time ya? What are the other switches that it could be? I think I read somewhere that there is another switch to check that the car is in "d" drive. Maybe I need to pull my shifter cover off and look to see that the sensor is realizing I am in drive. Although my instrument cluster does show I am in "d" and I would assume its the same switch so I don't know if that is it.

More ideas guys?

J. R.

Link to post
Share on other sites

Check the brake switch, if that is has loosened up and moved cruise control will not engage. Since the cc was designed to dis-engage when the brakes are pressed, it will generate no error codes.

That is a good idea. If that was the case though my brake lights would be on all the time correct? So I can check that switch, but also rule out that being the problem if my brake lights aren't on all the time ya? What are the other switches that it could be? I think I read somewhere that there is another switch to check that the car is in "d" drive. Maybe I need to pull my shifter cover off and look to see that the sensor is realizing I am in drive. Although my instrument cluster does show I am in "d" and I would assume its the same switch so I don't know if that is it.

More ideas guys?

J. R.

Another possibility is the speed sensor that turns off the cruise control below a certin MPH. Although it may be working, perhaps the proper signal is not getting to the cruise control, as it thinks that the car is below the threshold speed. No CEL codes would be generated under this condition.

I don't have a wiring diagram so that's as far as I can go.

Just a thought though

Phil

Link to post
Share on other sites

Both the speed sensor, and "D" drive sensor are other possibilities, but one thing that you must keep in mind is that some of these switches / sensors have more than one "section" IE such as the brake switch. One section will control the brake lights, and one is a input to the cruise control. Just because one section is working, does not indicate that the other is.

Now checking the brake lights is a good idea, if the lights are on all the time it would indicate what you next step would be. If the lights are working correctly you may still have a problem with the switch. So with that in mind, you can check the basics that have allready been mentioned. If you do not see the problem, you will need to get a schematic to take it further.

Link to post
Share on other sites

Both the speed sensor, and "D" drive sensor are other possibilities, but one thing that you must keep in mind is that some of these switches / sensors have more than one "section" IE such as the brake switch. One section will control the brake lights, and one is a input to the cruise control. Just because one section is working, does not indicate that the other is.

Now checking the brake lights is a good idea, if the lights are on all the time it would indicate what you next step would be. If the lights are working correctly you may still have a problem with the switch. So with that in mind, you can check the basics that have allready been mentioned. If you do not see the problem, you will need to get a schematic to take it further.

I will check those. I really do need a wiring schematic with voltages I should be checking for. Can anyone that has the FSM take a screen shot of the cruise control trouble shooting page if such a page exists and post it on here?

J. R.

Link to post
Share on other sites

Ok,

I found a FSM for a camary v6 but it should be the same I hope...... But it gave me a good idea of what could trip the cruise control to not set. Also some voltages to check assuming the lexus really is the same.

Here are some pics for people that find this thread and need help also.

post-14672-128386652037_thumb.png

post-14672-12838665258_thumb.png

post-14672-128386653038_thumb.png

post-14672-128386653502_thumb.png

Link to post
Share on other sites

since I hate it when people never write the conclusion.......

I fixed it today. I couldn't find a FSM for a lexus but I did for a v6 cam. I used a paper clip jumper on the cruise control diagnostic port and the cruise control light still flashed no codes.

So I followed the FSM for what it says to do when all checks normal.....first up is to check the wiring and connector at the cruise control box. I pull the 4 pin connector off, and once off reveal that the red with black stripe wire is striped and barely holding on.....by a thread. In my removal of that connector I broke it the rest of the way. So I re-spliced the wire together with a butt connector and took the car for a drive.

CRUISE WORKS GREAT!

So there is the thread update for those who find this thread in the future.

J. R.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...