Sign in to follow this  
Francisco

Outside Temperature Display Changed From F To C

Recommended Posts

This morning I noticed that the Outside temperature display on my 2001 RX300 is displaying in Celsius instead of Fahrenheit. The inside temperature does display in Fahrenheit as always. Does anybody know how to restore the Outside Temperature display back to Fahrenheit?

It is worth mentioning that the cause might be the fact that I did not properly close a car door last night and the battery had drained some. I was still able to start the car and did not notice any other "side effects".

Thanks!

Share this post


Link to post
Share on other sites

As it turns out, the next time I turned the car on the outside temperature was displaying correctly in F. So I'll write this off as a fluke.

Share this post


Link to post
Share on other sites

That strange huh.gif Keep an eye on this and post if it occurs again. cheers.gif

Share this post


Link to post
Share on other sites

Sorry about resurrecting this old thread but I am having the same problem as the original poster...except my units will not change back to F. Anyone figure out this very strange occurrence?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this