Do Not Sell My Personal Information Jump to content

Recommended Posts

Hello All,

My SC400 has developed a nasty little steering leak. I think I am going to try a leak sealer substance of some sort first. Id like to know what types you guys have used that will not screw up the system. My local Lexus / Toyota specialist shop took a look and said oh you need a new pump and reservior. That will be a 1000 plus bucks. I am contending with the Lexus Wallet to be picked image I think.

Thoughts? Opinions?

I definatly appreciate you guys and what I have learned here thus far.

Thanks,

Walt

Link to post
Share on other sites

Hello All,

My SC400 has developed a nasty little steering leak. I think I am going to try a leak sealer substance of some sort first. Id like to know what types you guys have used that will not screw up the system. My local Lexus / Toyota specialist shop took a look and said oh you need a new pump and reservior. That will be a 1000 plus bucks. I am contending with the Lexus Wallet to be picked image I think.

Thoughts? Opinions?

I definatly appreciate you guys and what I have learned here thus far.

Thanks,

Walt

Sorry to hear about your problem, i had something similar to this and was also told to replace a lot of parts. after taking it to a really good mechanic it turned out all i needed was a $5 replacement bolt. So make sure that you are definate about were the leak is coming from.

Link to post
Share on other sites

Hello All,

My SC400 has developed a nasty little steering leak. I think I am going to try a leak sealer substance of some sort first. Id like to know what types you guys have used that will not screw up the system. My local Lexus / Toyota specialist shop took a look and said oh you need a new pump and reservior. That will be a 1000 plus bucks. I am contending with the Lexus Wallet to be picked image I think.

Thoughts? Opinions?

I definatly appreciate you guys and what I have learned here thus far.

Thanks,

Walt

Sorry to hear about your problem, i had something similar to this and was also told to replace a lot of parts. after taking it to a really good mechanic it turned out all i needed was a $5 replacement bolt. So make sure that you are definate about were the leak is coming from.

Got a rebuild PS pump for $145, clean everything out first as the hoses may be leaking.

Link to post
Share on other sites

Also it is believed that the filter within the solenoid in the power steering rack can cause this leak. The filter which is a fine metal screen becomes clogged after time. I had this happen to my sc400, but I changed out the power steering pump, cleaned the solenoid screen, flushed out the power steering system, and also had to change out the alternator. And everything has been working great since then. Very common problem among these cars. Usually its just the power steering pump that will leak, but make sure its not within the high pressure hoses. There's a lot of info. on this topic.

If you do find it just to be the power steering pump I wouldn't waste time with the leak sealer. I would just pick up a remanufactured power steering pump for approx. $150.00. I would also clean the screen when installing the new pump.

Link to post
Share on other sites
  • 3 weeks later...

Actually my BIGGEST problem is finding a shop that I want to trust. The local Toyota specialist charges almost as much as the dealership for labor. And no loaner car or free wash.

I changed the power steering pump and alternator for $300 at my local mechanic. That includes labor. He uses remanufactured parts but they last just as long and i'v had it working over 2 years without a leak.

Link to post
Share on other sites

Hello All,

My SC400 has developed a nasty little steering leak. I think I am going to try a leak sealer substance of some sort first. Id like to know what types you guys have used that will not screw up the system. My local Lexus / Toyota specialist shop took a look and said oh you need a new pump and reservior. That will be a 1000 plus bucks. I am contending with the Lexus Wallet to be picked image I think.

Thoughts? Opinions?

I definatly appreciate you guys and what I have learned here thus far.

Thanks,

Walt

My SC300 was leaking a little but my P/S was not working at low RPMs, I changed my connecters and hoses, and now, there is no more leak. I sprayed degreaser, cleaned everything, dry and nice. It had stayed that way for 2 weeks now.

But my powersteering still does not work at low rpms. (need 2000 rpm to work) I checked my solenoid filter, but it seems to be working and they are new. (Came with my $500 hose)

I have spent $600+ so far, and my leaking stopped by still no P/S at low speeds.

Getting a remanufactured pump next.

:(

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...