Jump to content


Trac Light On


Recommended Posts

My '93 SC300 has a light on the dash that says "TRAC" Not the one that comes on when you turn off the traction control. Owners manual says to take it to the dealer, can anyone tell me what this means, and what I can do about it?

Thanks, Steve

Link to comment
Share on other sites

It is the only light on, no check engine light, and the brakes work fine.

It just says "TRAC" in the middle of my tachometer.

Hey...

FWIW: the owners manual says to take it in... usually has to do w/ an failure in the sys.

BOL on findin' a fix.

Link to comment
Share on other sites

Since you asked nicely, it refers to the traction control unit. Usually throwing an error code when it thinks theres a problem. Mine did that for about 2 months and I ignored it and it went away. Try this, drive around with the trac off for a few days, so everytime you start the car up turn the trac off. This may refresh previous codes and act as a new install if the unit doesn't run for a while when the cars in normal operation. Actually, does the Trac light automatically come on when you start the car up and before its put into gear?

Link to comment
Share on other sites

Since you asked nicely, it refers to the traction control unit. Usually throwing an error code when it thinks theres a problem. Mine did that for about 2 months and I ignored it and it went away. Try this, drive around with the trac off for a few days, so everytime you start the car up turn the trac off. This may refresh previous codes and act as a new install if the unit doesn't run for a while when the cars in normal operation. Actually, does the Trac light automatically come on when you start the car up and before its put into gear?

also a "hack" may be to disconnect the battery & re-connect... this may re-set the system as well. know it works w/ p-cars w/ obd. this may be only a temporary solution. but like forementioned... maybe the trac threw an error code & simply needs to reset.

BOL

Link to comment
Share on other sites

  • 2 months later...
Since you asked nicely, it refers to the traction control unit. Usually throwing an error code when it thinks theres a problem. Mine did that for about 2 months and I ignored it and it went away. Try this, drive around with the trac off for a few days, so everytime you start the car up turn the trac off. This may refresh previous codes and act as a new install if the unit doesn't run for a while when the cars in normal operation. Actually, does the Trac light automatically come on when you start the car up and before its put into gear?

also a "hack" may be to disconnect the battery & re-connect... this may re-set the system as well. know it works w/ p-cars w/ obd. this may be only a temporary solution. but like forementioned... maybe the trac threw an error code & simply needs to reset.

BOL

Another suggestion to reset possible code alert - pull the trac 7.5 fuse under the hood, leave it out for a while (dunno how long), then put it back in. That should reset any coding issue, heh? Works great on my Mazda that keeps giving me a check engine light, coding for excessing exhaust gas recirc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Forums


News


Membership