Jump to content

92 Ls400 Stero Speakers


Zoso
 Share

Recommended Posts

Hey guys I have a 1992 LS400 with the Pioneer system in it. The system still works great but the rear center deck speaker is not working. Does anyone know where I can get an oem replacement for it besides having to give up my first born child to my Lexus dealer!? I also have one torn speaker cover in the rear door. Does anyone know where I can get a replacement for it? Have you guys switched these components out? Do you have some suggestions? All comments appreciated. Thanks!

Link to comment
Share on other sites


I too discovered today that my 92 LS400 has a non functioning rear center speaker. I am thinking of having the dealer diagnose it, but has anyone found a problem with the head unit or the speaker which may be responsible for this? Maybe this is a common problem with a common solution.

Thanks.

Link to comment
Share on other sites

  • 6 months later...

i replaced mine with a rockford 8inch sub. Works very well, but the stock sub woofer unit has a built in mount that i need to hold the speaker in place or else it will rattle. I have to drill holes soon to fix it. Another thing is that the center speaker is not well powered. It isnt pushing enough wattage so you can hear and feel enough omph. My friend sugguest that i'd get an amp for it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership