AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




Recommended Posts

I have a 97 es300. Over 3 hundred thousand miles on it. Bought it for $600 top of this year February 2017 for those that ask. The last owner did not take very good care of the car at all but I needed a car to get myself to work & back home.

Anyways, I know my struts are out but whenever I drive on dry roads the car is fine. But whenever it rains it gets stupid. The car would drive all over the place not staying steady. I'm sure I just gave myself a answer but keep in mind the tires are new. Shouldn't be a problem. However, when it did rain back couple of months back I would be able to drive the car fine aswell. This is why it's not making any sense to me. Can anyone help me out with this problem to why the car is doing this other than get new struts & good luck with that lol I know the mechanic wants $500 or more for the labor.

Thanks in advance

Share this post


Link to post
Share on other sites
 

Hi...welcome to the Club

Sounds like it is tyre related .... tyres fitted in the wrong direction? wheel alignment out? incorrect tyre pressures?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By visionatsea
      Rain sensing wipers are slow to come on when it rains and may come on when it is not raining!!  Anyone else have this problem?  How did dealer solve problem?
    • By Stevec57
      New owner here. This forum is full of great info for new guys!
      Just bought an '02 LS430. Low mileage, one owner.....love the car. Still had the original nav disc so I bought the newest one from local dealership. "I" scratched it while trying to install it. Bought another one and installed this morning (very careful as not to scratch it) and got the "cannot read disc" thing. Went back to dealer to have them check it out and they pulled out the disc. It was scratched in a circular motion. Obviously the reader did it. BUT, the original disc goes in, no scratches and works great. What's up? Do I need to replace the reader? Already spent almost 400.00 and still no updated navigation......frustrating. Haven't tried disconnecting power. Will try a cleaning disc. Any suggestions?