hammer008

2007 gx470 Air conditioner blowing cold air only on passenger side

Recommended Posts

I have been trying to fix my air conditioner for a month now as it only blows warm air or cold air only on the passenger side on a good day.

 

1.  Put new refrigerant.....worked for 2 weeks

2. put dye in to check for leaks....no leak visible using UV light

3.  changed both valve cores + more refrigerant....worked great for 2 weeks.

 

Anyone have any idea where I can look at next?  Where is the most probably leak area?

 

Share this post


Link to post
Share on other sites
 

Are you saying that when it blows cold air on one side (passenger) at the same time it is blowing hot air on the other side (driver) or vica versa?   Trying to understand if if the WHOLE SYSTEM is either hot or cold.    OR if it is a SIDE thing where the two SIDES are different.

Share this post


Link to post
Share on other sites

It blows warm outside air on driver side and cold ice air on the passenger side...so here is the cycle...

 

1.  fill with refrigerant....ice cold air on both sides for about 2 weeks....after warm outside air on the driver side and cold air passenger side for about 1 week...after warm outside air on both sides....rinse and repeat with  more refrigerant...

I have also replaced the AC relay in the fuse box to no luck.

Share this post


Link to post
Share on other sites

Interesting.  OK, I was going down path of problems with the servos that control the flow under the dash.  Mine was doing that, hot on one side and cold on the other, but never completelty went to hot on both.  Mine was actually the servos and I could here them making noises for years and then they failed.   Sounds like you actually have a leak.

Share this post


Link to post
Share on other sites

Well, here goes my ordeal. 

1.  Mechanic said he doesn't like the sound of the compressor....only have original compressor available (no rebuilt) so replaced  $2000+2 hour labor=$2200

2.  Cool but not cold...Mechanic said probably should replace the condenser and dryer may be clogged....$300+ 2hour labor=$500

3.  After 1 week....warm air again....found a huge puddle on driveway behind the rear passenger wheel...Mechanic was surprised there was a separate evaporator at back...said needs to cap of the rear  $300.

Working now but only in the front.    :(      Kids not happy for no instant cold in rear.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...