Sign in to follow this  
mosprott

Really Really Stupid Question

Recommended Posts

I've been keeping tabs on my brother's RX 300 for the past few months; I've started it occasionally, but haven't driven it around much.

It's been a few weeks since I started it. I went out to check it today, and the keyless remote didn't work, and the ignition didn't turn over (or make a noise, for that matter)--no lights, no nothing.

My car (a '96 Suzuki) doesn't have keyless entry or automatic anything...so I don't know how this is supposed to work. Is this a function of a battery in the keyless remote dying? Or is the car battery just dead, dead, dead?

Any thoughts would be appreciated!

--mms

Share this post


Link to post
Share on other sites

It sounds like your battery is dead. Maybe the interior light was on and drained the battery. Charge the battery and you should be OK.

Share this post


Link to post
Share on other sites

With the keyless remote, clock and cd changer on board there is a constant drain (although small) on the battery. You should be able to jump start the vehicle and then drive it for about thirty minutes. Should be fine. Either drive it once a week or disconnect the battery if it will be awhile between starts.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this