Do Not Sell My Personal Information Jump to content

Amplifier Calls It Quits


Recommended Posts

I have owned a 1992 sc300 for 5 years. I love this car. My stereo seems to be working, but no sound. A few posts seem to say it is the amplifier to blame. OK, so I take a look at the problem amp under the cd changer to write down a model number. To my surprise it is a Pioneer amp. I did not know my husband put a Nak stereo in the car, but did not change the amp. So, my question is this: Can I replace the Pioneer amp with a Nak with no problems? Will it plug in just fine? I guess I am lucky to get five years out of this mismatched pair.

Link to post
Share on other sites

It might not be the amp, if you have the original speakers still in the car they probably have deteriorated? To test the rear speakers take down the lining and locate the +/- connections. Buy a cheap 2" speaker and connect, if you hear sound your stock speakers are blown.

if blown these are the steps you will have to take for the rear in post#2.

http://us.lexusownersclub.com/forums/index.php?showtopic=65329

For the front speakers http://clublexus.com/forums/lexus-audio-video-security-and-electronics/109384-speaker-install-how-to-with-tons-of-pics-sc3-400-a.html

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...