Sign in to follow this  
tsantoro

Check Vsc And The Check Engine Light Appeared

Recommended Posts

Any suggestions as to the problem and fix? The gas cap is tight.

I had this warning light come on after I had the valve springs replaced on my IS350 with the factory recall. Engine started shutting down and running very poorly. Took it back to the dealer and I was told that a module had come loose that the mechanic had not put on correctly. It was a quick fix and no further problems.

Share this post


Link to post
Share on other sites

Any suggestions as to the problem and fix? The gas cap is tight.

I had this warning light come on after I had the valve springs replaced on my IS350 with the factory recall. Engine started shutting down and running very poorly. Took it back to the dealer and I was told that a module had come loose that the mechanic had not put on correctly. It was a quick fix and no further problems.

Thanks, tsantoro

Share this post


Link to post
Share on other sites

once happend to me that VSC appeared for no reason and acceleration and turbo dissapeared. my friend told me to take off the battery for a minute to remove the error. i did it and error disapeared.

Share this post


Link to post
Share on other sites

Any suggestions as to the problem and fix? The gas cap is tight.

I had this warning light come on after I had the valve springs replaced on my IS350 with the factory recall. Engine started shutting down and running very poorly. Took it back to the dealer and I was told that a module had come loose that the mechanic had not put on correctly. It was a quick fix and no further problems.

so since this happened after you recall, did you have to pay for anything for them to get rid of the light (fix it). Im on extended warranty and kinda afraid that it will cost me an arm a leg to fix it.

Share this post


Link to post
Share on other sites

Likely an Air/ Fuel sensor. Take it to Autozone and get them to scan it for the code. That will tell you which one needs to be replaced.

Share this post


Link to post
Share on other sites

Likely an Air/ Fuel sensor. Take it to Autozone and get them to scan it for the code. That will tell you which one needs to be replaced.

man.. i would hate to take it to autozone but i guess im going to have to just to make sure. are there any alternative besides autozone? either way, the light turned off after i unplugged the battery and plug it back in, though i still want to make sure everything is fine.

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this