Sign in to follow this  
Nickjai RX

Nav Issue Need Some Help!

Recommended Posts

Hey i need some help with my RX330 nav issue, when im driving the nav's map just keeps spinning in circles when in motion and when stopped. I've posted this topic on another forum as well and they said that there might be something wrong with my ECU :cries:. Im just wondering if anyone else has come across this same problem. I've also uploaded a video of what my navi is doing since its very hard to explain my issue.

Share this post


Link to post
Share on other sites

Can you go into the menu? Maybe try entering in a destination? You could also try disconnecting your battery to see if that would do it. Where you doing anything before this happened?

Share this post


Link to post
Share on other sites

Wow i've definitely never seen that before.

At the top left of the screen you'll notice a little "compass" icon. If you click it, you can toggle between map views. Either 1: top of map always points north, or 2: top of map always points straight ahead. Does the map still do this in both map view settings?

Also try what LEXIRX330 suggested.

Share this post


Link to post
Share on other sites

Can you go into the menu? Maybe try entering in a destination? You could also try disconnecting your battery to see if that would do it. Where you doing anything before this happened?

yeah I can set a destination and it calculates the routes for me but when I'm driving it doesn't tell me where to turn anymore. The system doesn't talk to me anymore. Lol so sad.... I waesnt doing anything to it I was just driving and all a sudden the map just kept spinning in circles. I was hoping it would fix itself but it never happended.

Share this post


Link to post
Share on other sites

Wow i've definitely never seen that before.

At the top left of the screen you'll notice a little "compass" icon. If you click it, you can toggle between map views. Either 1: top of map always points north, or 2: top of map always points straight ahead. Does the map still do this in both map view settings?

Hey... Yeah I've tried doing that already so when I choose the map to alway point north.... Only the arrow of my car spins, and when I choose option 2 that's when the whole map spins and it drives me nuts.

Also try what LEXIRX330 suggested.

Share this post


Link to post
Share on other sites

Hey... Yeah I've tried doing that already so when I choose the map to alway point north.... Only the arrow of my car spins, and when I choose option 2 that's when the whole map spins and it drives me nuts.

Hmm... this tells me that the nav system "thinks" the car's actually spinning, vs the the screen just spinning for no reason.

If you were actually spinning, the screen would do exactly what it's doing now. My thinking is that, if it were an ECU problem, the screen would rotate in both modes, independently of the position of the car. My guess is that some sensor (the one that detects your location) is telling the nav system that you're spinning when actually you're not.

I couldn't tell from the video, but if you're traveling along a road or highway, does the arrow still indicate your correct position at all times (relative to intersections, etc)? Or does it just remain in one location spinning round and round, even though you're moving...?

It's also weird that the voice activation doesn't talk to you...

Share this post


Link to post
Share on other sites

Hey... Yeah I've tried doing that already so when I choose the map to alway point north.... Only the arrow of my car spins, and when I choose option 2 that's when the whole map spins and it drives me nuts.

Hmm... this tells me that the nav system "thinks" the car's actually spinning, vs the the screen just spinning for no reason.

If you were actually spinning, the screen would do exactly what it's doing now. My thinking is that, if it were an ECU problem, the screen would rotate in both modes, independently of the position of the car. My guess is that some sensor (the one that detects your location) is telling the nav system that you're spinning when actually you're not.

I couldn't tell from the video, but if you're traveling along a road or highway, does the arrow still indicate your correct position at all times (relative to intersections, etc)? Or does it just remain in one location spinning round and round, even though you're moving...?

It's also weird that the voice activation doesn't talk to you...

I've never tried actually going in circles with the car lol.... The gps is accurate on the street that I'm on but it just likes to spin in circles, I'm guessing it has something to do with one of the sensors as well. Ever since this issue it never displays the street name that I'm currently driving along anymore and I have the street name feature turned on in the setup screen.

Share this post


Link to post
Share on other sites

I would call your lexus dealer and see if they can offer you any insight... This is incredibly odd. :wacko:

Share this post


Link to post
Share on other sites

I would call your lexus dealer and see if they can offer you any insight... This is incredibly odd. :wacko:

I've already been to the stealership, and the tech does not know what wrong. He just wants me to replace the while ecu unit.

Share this post


Link to post
Share on other sites

Call a different dealer. Try disconnecting the battery...see if it resets? It is worth a try. Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this