Do Not Sell My Personal Information Jump to content

Default Engine Check Light/vsc On/code P0355


Recommended Posts

Hi-

I have 07 RX350 with 75k miles. We bought this car 3 months ago and it is our first Lexus. Car was working great until engine light check came on with VSC.

I have checked gas cap and it is tight. I went to Autozone and scanner shows code P0355 Primary/Secondary E Coil. Car is running fine but some time feels some jerkiness.

My question is what else can I do beside taking it to a dealer? called local mechanic and he told me that coil is in the back and labor would be worth replacing 3 coils. Any suggestions would be appreciated. Is this something I can change? I am no pro but can do many things around the house

Thanks again for your time and help!!!

Link to comment
Share on other sites

  • 1 month later...

Hi Friend, I don't have the answer, but wanted to validate the symptoms your RX is having.....mine is doing the EXACT same thing. Vehicle is '07 RX-350 , 76k miles, has " VSC, Traction Off, and Check Engine" light.....also idling a little rough with a slight "missfire" ??? It just started a couple days ago. If you have found the solution, I would love to know what you came up with...Thanks and Best of luck

Link to comment
Share on other sites

  • 2 weeks later...

Wife called me just now... Same problem...Check Engine/VSC/Trac Off. So strange. This has been a great car for us, a true work horse so to speak with the amount of driving/kid and grocery hauling we do, will schedule an appointment with Lexus today and see what the problem is. Will update the forum (for anyone interested) when I hear back. ps, ours has about 48K miles...

Link to comment
Share on other sites


  • 3 weeks later...

Wife called me just now... Same problem...Check Engine/VSC/Trac Off. So strange. This has been a great car for us, a true work horse so to speak with the amount of driving/kid and grocery hauling we do, will schedule an appointment with Lexus today and see what the problem is. Will update the forum (for anyone interested) when I hear back. ps, ours has about 48K miles...

***Follow up: it was ignition coil #5 that had failed.... dealer fixed under extended warranty. problem is gone, car is back to its 'before' power.***

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership