Jump to content


07 350rx - Omg - White Dust!


Recommended Posts

so this is Certified Lexus with 65000 miles, warranty to 100K. New cabin filter less than 6000 miles ago

seems strange to see this stuff now, all the posts I read problem seems to have started early in the life of the car.

Anyway the heater works fine, I dont have a smell, I may be parnoid... :( :rolleyes:

suggestions? Other ways to test?

Link to comment
Share on other sites

Cabin filter has nothing to do with it and there isn't any odor. They need to replace part of the heating unit. I had medical issues that resolved immediately after having this taken care of. Lexus still won't accept any responsibility beyond doing the fix and won't respond to my questioning why there hasn't been a recall. I know that everyone reacts differently to irritants but I also know what I went through and feel people should be notified. In any case, bring it in and have them replace the part, clean out all the vents and thoroughly vacuum/clean the interior.

Link to comment
Share on other sites

  • 3 weeks later...

Is this dust just something that comes about when the heat comes on or does it happen with the A/C, too?

We barely use the heat here in AZ but I used it last week and saw the white dust. I just purchased this car last month so I didn't know about this problem until I came here to read the threads. Anyway, if this is something that only happens when the heat comes on, I may just skip on the repair. If it happens while using the A/C, which I use 9 months out of the year, than I probably need to get it fixed!

Link to comment
Share on other sites

  • 2 weeks later...
Is this dust just something that comes about when the heat comes on or does it happen with the A/C, too?

We barely use the heat here in AZ but I used it last week and saw the white dust. I just purchased this car last month so I didn't know about this problem until I came here to read the threads. Anyway, if this is something that only happens when the heat comes on, I may just skip on the repair. If it happens while using the A/C, which I use 9 months out of the year, than I probably need to get it fixed!

I only had the problem when the heat was being used. So far this winter no problems after having the heater core replaced.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Forums


News


Membership