Sign in to follow this  
joedoc

Possible Leaky Injectors In 92 Sc400

Recommended Posts

my sc400 normally starts up just fine, but after sitting an unusually long time (1-2 days) it will start rough and give a noticeable gas smell for a few minutes. I thought this might be injectors leaking, tried some techron without help. Would appreciate any ideas.

Share this post


Link to post
Share on other sites

It's normal. I'm experiencing the same problem with my SC300. I believe it's due to the cold weather. You could spay some solvent on the battery terminal, and if you want to you could replace the starter, but it depends on whether your car has high mileage and the starter hasn't been replaced before.

The smell, I'm not quite sure about, but it could be due to cold fuel entering your engine.

Share this post


Link to post
Share on other sites

i have a 92 sc400 that does the same thing, its normal. the smell could be you exhaust burning built-up dirt and things. and the rough start, you can do what i did, replace your starter cable with a monster 4-gauge wire.

Share this post


Link to post
Share on other sites

thanks for the tips, will try. had heard that injectors could leak down some pressure overnight, causing rich, rough start---had assumed that was the problem. the starter motor seems strong, the roughness occurs after the starter seems to have done its job. will check those connections though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this