Do Not Sell My Personal Information Jump to content

Need Help


Lifeman89
 Share

Recommended Posts

So my Friends 03 es300's ac is not blowing cold air anymore. I'm not familiar with anything lexus so first i looked for a fuse and did not find a fuse in the marked location for the ac. next i tested the lines they are charged the car has under 50,000 miles on it any advice where to start looking for issues?

Link to comment
Share on other sites

So my Friends 03 es300's ac is not blowing cold air anymore. I'm not familiar with anything lexus so first i looked for a fuse and did not find a fuse in the marked location for the ac. next i tested the lines they are charged the car has under 50,000 miles on it any advice where to start looking for issues?

First check to see if the compressor is still operating. Then look for the sight glass and see if there is any bubbles floating in the system. If you see bubbles, it is possible that it is low on R-134A refrigerant cause by a leak.

N.C.O.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership