Do Not Sell My Personal Information Jump to content

Battery Drain


cherylsc430
 Share

Recommended Posts

My battery is new and has been checked, problem I have is that it keeps going flat after I haven't used the car for a week or so (prior to that only light use - say 20 miles/week for previous 3 weeks). Any ideas ? Is something draining my battery? No lights etc are on and the breakdown man said drainage current was ok. Can you disable the alarm but still use the immobiliser?

Link to comment
Share on other sites


You need to drive the car more often or hook it up to a charger to keep the battery charged. Your "driving" isn't enough to recharge the battery.

i have a mustang and it sits in the below freezing new england winters and still starts in the spring

Link to comment
Share on other sites

I dont use my car for a couple of weeks regularly. When I first got the car I often got a flat battery, after I stopped using the alarm it was fine.

If you can ie your car is garaged then dont set the alarm. Or get one of those switches fitted to the battery that disconnects the battery when it reaches too low, so as there is just enough juice left to turn the engine over.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership