Jump to content


Sylvania Silver Stars For Dlr/high Beams In 08 W/ Hid


Recommended Posts

hey all, have a new 08 rx350 with HIDs. going to get the dealer to aim the HIDs more up because they are aimed too low. I am somewhat annoyed that lexus did not use bi-xenon HIDs that do both low and high beams. Had I known, I would have not gotten it from them and put in my own HID kit...

Anyways, I was also going to replace the stock DLR/Highbeam bulbs with Sylvania silver stars - website says 9005S/SUs. was going to grab the 9005SUs from walmart.

anyone have any experience with these bulbs in their rx350? its not going to fry anything is it?

Link to comment
Share on other sites

hey all, have a new 08 rx350 with HIDs. going to get the dealer to aim the HIDs more up because they are aimed too low. I am somewhat annoyed that lexus did not use bi-xenon HIDs that do both low and high beams. Had I known, I would have not gotten it from them and put in my own HID kit...

Anyways, I was also going to replace the stock DLR/Highbeam bulbs with Sylvania silver stars - website says 9005S/SUs. was going to grab the 9005SUs from walmart.

anyone have any experience with these bulbs in their rx350? its not going to fry anything is it?

I suspect if you check more closely you will note that you do have bi-xenons and the HB halogen is there for "fill" and for DRL.

The projector HID has a shading apperture for low beam which is moved out of the way via an eelctric solenoid in high beam mode.

The lead car on the left has the same bi-xenon arrangement.

Link to comment
Share on other sites

I first noticed this on my '01 AWD RX300, at fairly low miles the glass encapsulation for the high beam bulbs was internally "sooted" over and there was a bubble in the glass above the filament. I had upgraded to PIAA higher wattage bulbs so I guess I wrote it off to that, PIAAs, although I had found documents on the internet in operating halogen bulbs as DRLs at low voltage could result in those effects.

Yesterday I had to replace a burned out low beam in our 95 LS400 (210,000 miles). In the process of replacing the high/low beam H4 bulb I noticed that the second high beam bulb (60W HB3/9005), the one used for DRL, looked odd, bluish. When I removed it it was as I described above for the RX300.

So those of you with high beams as DRLs might want to check the condition of the bulb.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership