Sign in to follow this  
crow1

Parking Brake Instrument Light Comes And Goes

Recommended Posts

The parking brake instrument light comes on and off...without the brake being applied. Is there a sensor that needs cleaning or what would be another diagnosis?

thanks in advance.

Share this post


Link to post
Share on other sites

you are probably low on Brake fluid......check that first and foremost.......

those sensors in the resevoir are very sensitive, i had that happend b/f and it was only a 1\4 of an inch below and it triggered the light

good luck

Share this post


Link to post
Share on other sites

I have a similar problem. A bright parking brake light indicates your parking brake is engaged. A dimmed parking brake light indicates low brake fluid. Check the fluid ASAP. My parking brake light dims after I release the parking brake and I have checked my fluid carefully. I haven't solved this problem. From the manual it looks like it might be a switch behind the lower dash.

glenmore

1990 LS400

1991 300CE

Share this post


Link to post
Share on other sites
A bright parking brake light indicates your parking brake is engaged. A dimmed parking brake light indicates low brake fluid. Check the fluid ASAP. My parking

interesting, my light has one setting: the light is either ON or OFF.........and its the same light

you might have a bad switch in there or bad wire, like you mentioned, cause i've never seen or heard of the light being brighter or dimmer indicating a different problem. <_<

Share this post


Link to post
Share on other sites

The parking brake light comes on ocasionally on my 04 LS430 and did the same in my 01 LS430. I just hit the parking brake release gizmo and it goes away. It might do it 5-10 times per year.

Share this post


Link to post
Share on other sites
The parking brake light comes on ocasionally on my 04 LS430 and did the same in my 01 LS430.  I just hit the parking brake release gizmo and it goes away.  It might do it 5-10 times per year.

i hit mine at least 5 times DAILY! the connector fro the parking brake inside the console is loose. :blink:

Share this post


Link to post
Share on other sites
you are probably low on Brake fluid......check that first and foremost.......

those sensors in the resevoir are very sensitive, i had that happend b/f and it was only a 1\4 of an inch below and it triggered the light

good luck

you were right on. Added very little fluid and no more light.

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this