Jump to content


Emergency/ Parking Brake Light Indicator


Recommended Posts

I have a new 2003 Lexus GS-300. It’s not driven every day. When I go to start the car after a few days of being in garage the parking brake light indicator is lit. I had it in for the 1000-mile check up and informed them of this problem. They did the normal topping off of fluids and stuff but the problem still exists. Anybody else ever have this problem and if so what was the solution?

Link to comment
Share on other sites


I have a new 2003 Lexus GS-300. It’s not driven every day. When I go to start the car after a few days of being in garage the parking brake light indicator is lit. I had it in for the 1000-mile check up and informed them of this problem. They did the normal topping off of fluids and stuff but the problem still exists. Anybody else ever have this problem and if so what was the solution?

It could be one of two things.

1. A bad ground wire connection on the light relay or

2. The brake is depressed enough to ingage the light relay.

I would most likely think it is a bad ground wire.

Hope this helps.

Link to comment
Share on other sites

  • 4 years later...
I have a new 2003 Lexus GS-300. It’s not driven every day. When I go to start the car after a few days of being in garage the parking brake light indicator is lit. I had it in for the 1000-mile check up and informed them of this problem. They did the normal topping off of fluids and stuff but the problem still exists. Anybody else ever have this problem and if so what was the solution?

It could be one of two things.

1. A bad ground wire connection on the light relay or

2. The brake is depressed enough to ingage the light relay.

I would most likely think it is a bad ground wire.

Hope this helps.

I've very similar problem in my lexus rx300, except that it blinks abrubptly and I think too that it is bad ground wire. Does anyone know how to fix that ?

Link to comment
Share on other sites

  • 2 months later...
I have a new 2003 Lexus GS-300. It’s not driven every day. When I go to start the car after a few days of being in garage the parking brake light indicator is lit. I had it in for the 1000-mile check up and informed them of this problem. They did the normal topping off of fluids and stuff but the problem still exists. Anybody else ever have this problem and if so what was the solution?

I have a 99 lexus gs300 with 85k miles. I have the same problem - when it happens I pull the emergency brake release lever as if the brakes were on and the light goes off. I have not checked into the cause but on mine I would guess the release switch needs adjustment.

Link to comment
Share on other sites

  • 2 months later...
I have a new 2003 Lexus GS-300. It’s not driven every day. When I go to start the car after a few days of being in garage the parking brake light indicator is lit. I had it in for the 1000-mile check up and informed them of this problem. They did the normal topping off of fluids and stuff but the problem still exists. Anybody else ever have this problem and if so what was the solution?

Your post was from a long time ago; however, I found it because my 2003 GS300 has the same issue. The parking brake light will light up after starting the car. It is not consistent.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership