Jump to content


Strange Buzzing Noise Coming From The Ac/heating System


67cougar
 Share

Recommended Posts

I am trying to identify a strange buzzing noise which comes from the AC/Heating System. The buzzing noise starts when I first start the car most of the time. However, it is intermittent and goes on and off when the AC/Heating System buttons are pushed. The system seems to be working all right. But the buzzing would seem to indicate that something is either bad or going bad.

Has anyone else had this problem?

The RX300 has 180,000 miles and runs very well.

Also, I have a question concerning the timing belt replacement. The belt was replaced at 90,000. Should it be replaced again at 180,000?

Thank you for your responses.

Link to comment
Share on other sites

Hi, ref. your first question, this is probably your A/C pulley assembly. From other forums, quite a common issue and not something which you can easily replace at home. So, best to consult a car mechanic.

Ref. your second question, the answer must be in your car's manual (from memory, it has maintenance tables for each 15,000 of mileage). Again from memory, on Lexus you have to replace the timing belt every 100,000 miles.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership