Jump to content


97 "throttle Lock"


frankenfoamy
 Share

Recommended Posts

For the last couple years I have returned my 97 LS400 for clunking sensation when accelerating and decelerating.

They can't find the problem unless I drive along and then it is very apparent. (imagine that) the tierods and motor mounts have been replaced. Now I am told that it is the normal "throttle lock" problem for the 1997. It did not have it when I bought so how is it normal?

The sensation is similar to "play" in a universal joint

I think is it is the carrier bearings in the rear suspension but I am told it is a problem in the transmission computer that can not be fixed

Link to comment
Share on other sites

  • 3 weeks later...

In the 7 years I have worked for one I never came across a "normal" throttle lock problem on one of them. Where did they pull that term out of. No bulletins or anything else to indicate that on LIS . They proballly gave up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership