Do Not Sell My Personal Information Jump to content

Pulls Left In A Right Hand Curve


lane602
 Share

Recommended Posts

My 1999 Lexus RX300 FWD has been an excellent vehicle. The transmission started changing rough and slipping going into overdrive at 129,600 miles. I took it to a reputable transmission garage and they rebuilt the transmission for $2500.00. They did a great job, transmission changes smoother than it has for years. They did me a favor and stayed with the $2,500.00 price even though after getting inside the transmission, it was a lot worse and needed more parts than they thought. They gave me a 2 year 24,000 mile warranty. My problem is, after getting vehicle back, when driving on our two lane roads here in the the mountains of western NC, when going around a right hand curve the rx300 feels like it goes to the left for a short distance,then I feel control again steering. The feeling is like I am slidding on a small patch of ice for a few feet then get control again. I had 4 wheel alignment and had them check all the fittings to front end, they had to adjust steering wheel a little and alignment was fine. The garage that did the transmission had the front frame out of vehecle to get the transmission out. Wondering it everything was put back right. Appreciate any feedback Rick

Link to comment
Share on other sites

My 1999 Lexus RX300 FWD has been an excellent vehicle. The transmission started changing rough and slipping going into overdrive at 129,600 miles. I took it to a reputable transmission garage and they rebuilt the transmission for $2500.00. They did a great job, transmission changes smoother than it has for years. They did me a favor and stayed with the $2,500.00 price even though after getting inside the transmission, it was a lot worse and needed more parts than they thought. They gave me a 2 year 24,000 mile warranty. My problem is, after getting vehicle back, when driving on our two lane roads here in the the mountains of western NC, when going around a right hand curve the rx300 feels like it goes to the left for a short distance,then I feel control again steering. The feeling is like I am slidding on a small patch of ice for a few feet then get control again. I had 4 wheel alignment and had them check all the fittings to front end, they had to adjust steering wheel a little and alignment was fine. The garage that did the transmission had the front frame out of vehecle to get the transmission out. Wondering it everything was put back right. Appreciate any feedback Rick

Accelerating, even slightly, into, in, the turn...?

In that case you might be experiencing more torque stear than you remember now that you have renewed the transaxle to factory spec's.

Torque stear will be more noticeable accelerating when turning in one direction vs the other, I don't remember which for the RX.

Link to comment
Share on other sites

Thanks for your input. Noticed it again yesterday, It does not do it all the time, It happens in only right hand curves and I am going at a steady speed and not accelerating or breaking.usaully around 35 to 40 mph. It is more like a slight pull or slide to the left for one or two seconds and it feels like the rx goes slightly left in the turn. I noticed it after bringing my vehicle home from the transmission shop. Transmission works and changes perfect, best it has since new. Had 4 wheel alignment after transmission rebuilt and that didnt help. Wondering it it has something to do with the left side transaxle. Thanks again

Link to comment
Share on other sites

Thanks for your input. Noticed it again yesterday, It does not do it all the time, It happens in only right hand curves and I am going at a steady speed and not accelerating or breaking.usaully around 35 to 40 mph. It is more like a slight pull or slide to the left for one or two seconds and it feels like the rx goes slightly left in the turn. I noticed it after bringing my vehicle home from the transmission shop. Transmission works and changes perfect, best it has since new. Had 4 wheel alignment after transmission rebuilt and that didnt help. Wondering it it has something to do with the left side transaxle. Thanks again

VSC defect..?

Light and beep indication of VSC or TC activation, indicator light period is so short you don't really have time to look down, considering your attentiona is elsewhere, and confirm, but beep....

If VSC "thinks" the car is over-stearing to the right it will lightly brake the left front wheel.

EDIT: Oops, sorry, you don't have TC/VSC...left front CV locking up momentarily..?

Link to comment
Share on other sites

Thanks for response, Took rx300 back to the transmission shop and they drove it and said they would fix it that day, They called about 3 hours later and said it was fixed. I asked what was wrong and all they told me was that a lock nut was not tightened all the way. Picked it up and it drives fine now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership