Sign in to follow this  
johntmeer

Gs300 Vsc/vsc-Off/abs Lights

Recommended Posts

Hey guys/gals, need some serious help here. Ive got a 2000 GS300, just lowered the car and put new rims on, car drove fine for a few days now the VSC, VSC Off, ABS, and Brake light came on and I lost my brakes completely. Ive read on here to check for the ABS sensors, front two measure 1.6k and the rear two measure 1.0k. Now Im not sure if both rears should measure between 1.4-1.8k as well. What I dont get is that the brakes are completely gone, I can drive it around and stop but it take a lot of force to get it to stop as if the booster is gone. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

You diagnosed it right. The abs sensors are bad. The back ones should read the same. Check them out. Could be cracked by the boot of it. If so, message me, i will let you know an easy fix for them under 10 dollars. With having the vsc, vsc off and abs lights on all at once, it also makes your engine run in limp mode as well which cuts your power output by 1/2. Also check your struts/shocks as they could have given out as well due to the lowering. change the lower ball joints in the front as well since they will snap and you will crap your pants when they do. :cheers:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this