Do Not Sell My Personal Information Jump to content

Rx450H Ipod Interface Issue


Recommended Posts

I was wondering if anyone else is having the same issue I am. I've got a 2010 RX450h with the factory iPod integration. The problem occurs in all screens of the iPod interface. Artists, Songs, Playlists, etc. When I scroll down the pages of the list it automatically starts to play the song/artist/playlist/etc. at the top of the list of each page. This is without moving the cursor, having it still over the arrow to scroll pages. I scroll down a page, it automatically starts playing whatever is at the top of that page. Scroll down one more page, it automatically starts playing the top of that page, etc. I took it in to the dealer and they said it is functioning as designed...in other words they've got no idea how that new fangled technology works. I think anyone would agree that this is not how an interface should work. Is anyone else experiencing this?

Link to post
Share on other sites

Yes, I get the same thing unfortunately. I found that if you scroll real fast, you can get through a few pages without the song starting. One of the problems is that when it plays the new song, it sometimes returns to the currently playing song screen, so you have to go back and pay with the menus to get tot he selection pages again. Crappy, crapy interface. It should be noted that when I plug in my iPhone, I usually get a message that the device is unsupported.

One glaring flaw in an otherwise nice ride.

Link to post
Share on other sites

I was wondering if anyone else is having the same issue I am. I've got a 2010 RX450h with the factory iPod integration. The problem occurs in all screens of the iPod interface. Artists, Songs, Playlists, etc. When I scroll down the pages of the list it automatically starts to play the song/artist/playlist/etc. at the top of the list of each page. This is without moving the cursor, having it still over the arrow to scroll pages. I scroll down a page, it automatically starts playing whatever is at the top of that page. Scroll down one more page, it automatically starts playing the top of that page, etc. I took it in to the dealer and they said it is functioning as designed...in other words they've got no idea how that new fangled technology works. I think anyone would agree that this is not how an interface should work. Is anyone else experiencing this?

Your dealer is right in one aspect, it is working as designed. However Lexus realized they designed it wrong and made an improvement mid year. Some 2010 models scroll as you would expect. There was a change in firmware. This improvement is not available (yet) to those of us with the older version of firmware.

I would suggest you call corporate Lexus, explain the problem and ask them to call your service advisor/manager so you can get the fix (if one is made) as soon as possible.

If you service advisor doubts any of this, find an RX in his lot with a manufacture date after January 2010 and plug in your iPod. It will scroll "properly".

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...