Sign in to follow this  
igbeserk

95 Es300 Throttle Body Doesn't Open All The Way

Recommended Posts

When I was taking apart parts of the engine to get to the knock sensor, me and my friend took a look at the throttle body it doesn't seem to open all the way it at most opens diagonally instead to the full horizontal. Then again i'm not sure if it's supposed to open all the way but from seeing other cars I believe it should. How could i resolve this issue? would i need to tighten something around there so the valve could open all the way? Any help would be appreciated. Thank you for your time.

Share this post


Link to post
Share on other sites

fixed the throttle body valve. it was the bottom chord the one that when you hit the gas the car pulls on to open it. for some reason it wasn't calibrated to the right position for it to open all the way. so i loosened the bolts around it and pushed it back until the valve opened all the way then i tightened it there. Car picks up like crazy now. getting to 80-100 with ease. hopefully it helps on the mpg it seems like it might have. but yea. at least that's one less issue.

Share this post


Link to post
Share on other sites

fixed the throttle body valve. it was the bottom chord the one that when you hit the gas the car pulls on to open it. for some reason it wasn't calibrated to the right position for it to open all the way. so i loosened the bolts around it and pushed it back until the valve opened all the way then i tightened it there. Car picks up like crazy now. getting to 80-100 with ease. hopefully it helps on the mpg it seems like it might have. but yea. at least that's one less issue.

Quick ? does it idle high and is it still driving good after that quick fix, I think I might need 2 do the same because after cleaning the MAF and the IACV on my 98 es300 it idling high and also has the same thing going on with the throttle body as well? thanks for any input

Share this post


Link to post
Share on other sites

fixed the throttle body valve. it was the bottom chord the one that when you hit the gas the car pulls on to open it. for some reason it wasn't calibrated to the right position for it to open all the way. so i loosened the bolts around it and pushed it back until the valve opened all the way then i tightened it there. Car picks up like crazy now. getting to 80-100 with ease. hopefully it helps on the mpg it seems like it might have. but yea. at least that's one less issue.

Quick ? does it idle high and is it still driving good after that quick fix, I think I might need 2 do the same because after cleaning the MAF and the IACV on my 98 es300 it idling high and also has the same thing going on with the throttle body as well? thanks for any input

no i don't remember it idling high it always seems to be at the same position. well check your throttle body it's supposed to open halfway if its not then you have to fix it. drives good, responds well, gets to higher speeds quicker.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this