Sign in to follow this  
erikfl

1999 Gs 300 Ac Blower Issue

Recommended Posts

I have a 1999 GS 300

A few weeks ago the blower for the AC started having issues.

The blower speed and output would take on a mind of it's own and blow at full speed then cycle to a slower speed then completely shut off (all while the control was set to maximum). Then after a few minutes it would turn back on and continue to cycle up and down. Some days it work fine, then the problem would repeat. Now for the past 2 days the blower does not turn on at all...

I am not sure if it is the blower controller module, a relay or even if the blower itself has bitten the dust.

Any suggestions would be appreciated.

Share this post


Link to post
Share on other sites

hi, did you find out what was wrong with your ac. i have a 1999 gs400 with the touch nav screen. i took it to a mechanic and he said i need a new ac control unit. i think it is something else. gonna take it for a second opinion. thank you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this