Sign in to follow this  
Xjust1nX

03 Is300 O2 Sensor

Recommended Posts

Hello Guys,

Can someone help me on this issue?

I got a 03 IS300 and the check engine light come on for 02 sensor.

how many 02 sensor do i have on the car and where it located at?

Bank 1 and Bank 2 wat that?

Share this post


Link to post
Share on other sites

Hello Guys,

Can someone help me on this issue?

I got a 03 IS300 and the check engine light come on for 02 sensor.

how many 02 sensor do i have on the car and where it located at?

Bank 1 and Bank 2 wat that?

Share this post


Link to post
Share on other sites

Hello Guys,

Can someone help me on this issue?

I got a 03 IS300 and the check engine light come on for 02 sensor.

how many 02 sensor do i have on the car and where it located at?

Bank 1 and Bank 2 wat that?

Share this post


Link to post
Share on other sites

when you pulled out the code did it say which sensor on which bank?

on my IS the bank 2 sensor 2 went bad. thats the hardest one, the one that is not on the manifold but the catback.

Share this post


Link to post
Share on other sites

when you pulled out the code did it say which sensor on which bank?

on my IS the bank 2 sensor 2 went bad. thats the hardest one, the one that is not on the manifold but the catback.

How many sensor are there on this car?

Share this post


Link to post
Share on other sites

when you pulled out the code did it say which sensor on which bank?

on my IS the bank 2 sensor 2 went bad. thats the hardest one, the one that is not on the manifold but the catback.

How many sensor are there on this car?

there are 4... 3 in the header and 1 in the y-pipe

Share this post


Link to post
Share on other sites

when you pulled out the code did it say which sensor on which bank?

on my IS the bank 2 sensor 2 went bad. thats the hardest one, the one that is not on the manifold but the catback.

How many sensor are there on this car?

there are 4... 3 in the header and 1 in the y-pipe

Do you know where is bank 1 sensor 2 at?

Share this post


Link to post
Share on other sites

I currently have a code P0420x2 and with the check engine light on my dash, my traction control off was blinkin a steady amount in like 30 second increments. I was told when that happens its usually refers to a bad o2 sensor. I was just wondering if there is confirmation on that or am I looking at multiple problems?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this