Sign in to follow this  
drew028

Srt Intake Low Idle With Piggy Ecu

Recommended Posts

Picked up a used srt kit the other and got it installed this morning. After installing the intake without the air filter (needed to by a new one) and little ecu the car had a low idle. I thought it would correct its self after getting the filter. During the 3 min ride to the auto parts store I could feel the difference. Not so much when punchng it but around 1.5 2000 rpm. After getting to the store and buying the filter I went out disconnected the battery poped on the filter and reconnected the battery. The cars idel was got worse and kept dieing. I got the on eway and played with it but the idel never corrected its self. It kept dieing if I didn't get it some gas. When I got home I pulled the srt ecu and the idle was fine. The car had a slight hesitation when punching it in drive not park. Did I miss something or do something wrong. If you think it will be easier to explain or help trouble shoot email me and I will respond with my number andrewmoctezuma@gmail.com. thanks!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this