Sign in to follow this  
dckstr

98 Es300 Sticky Gas Pedal

Recommended Posts

From a stop I get resistance in the gas pedal. A little more pressure and it seems to break free and it goes down about 1/2" before it begins to excellerate.It seems as if something is sticking. I have lubed all cables and linkage and the problem persists. This only occures when driving and only from a dead stop. I have worked the accelerator when the engine is off and can't detect any hitch or stickiness, everything seems to operate smoothly. Could the problem be a cable adjustment or something with the throttle body or plate?

Share this post


Link to post
Share on other sites
From a stop I get resistance in the gas pedal. A little more pressure and it seems to break free and it goes down about 1/2" before it begins to excellerate.It seems as if something is sticking. I have lubed all cables and linkage and the problem persists. This only occures when driving and only from a dead stop. I have worked the accelerator when the engine is off and can't detect any hitch or stickiness, everything seems to operate smoothly. Could the problem be a cable adjustment or something with the throttle body or plate?

i had the similar problem and it went away after cleaning the throttle body.

Share this post


Link to post
Share on other sites
From a stop I get resistance in the gas pedal. A little more pressure and it seems to break free and it goes down about 1/2" before it begins to excellerate.It seems as if something is sticking. I have lubed all cables and linkage and the problem persists. This only occures when driving and only from a dead stop. I have worked the accelerator when the engine is off and can't detect any hitch or stickiness, everything seems to operate smoothly. Could the problem be a cable adjustment or something with the throttle body or plate?

i had the similar problem and it went away after cleaning the throttle body.

Is this a big job or something I can handle myself?

Share this post


Link to post
Share on other sites
From a stop I get resistance in the gas pedal. A little more pressure and it seems to break free and it goes down about 1/2" before it begins to excellerate.It seems as if something is sticking. I have lubed all cables and linkage and the problem persists. This only occures when driving and only from a dead stop. I have worked the accelerator when the engine is off and can't detect any hitch or stickiness, everything seems to operate smoothly. Could the problem be a cable adjustment or something with the throttle body or plate?

i had the similar problem and it went away after cleaning the throttle body.

Is this a big job or something I can handle myself?

Problem solved.

I took off the air intake hose and top of the air box, then cleaned the throttle plate and what I could reach of the body with carb cleaner. Big difference, gas pedal is as smooth as silk, just like new. Easy fix. Thanks for the info.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this