Do Not Sell My Personal Information Jump to content

Turning Signal


Recommended Posts

My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

Link to comment
Share on other sites

i got the same h_lights on my sc4 and i had the same problem so i brought it to the performance shop and they said the wiring was all messed up and the light was all most finished he replaced the turn light and it never gave me any problem , well its only been 2 weeks lol but nothing yet , if your light is practically brand new then your wiring maybe the problem

Link to comment
Share on other sites

My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

It sounds like there's a short somewhere. check your tail light signal and see if you have a bad bulb. Did you have this problem before or after your housing swap?

Link to comment
Share on other sites

My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

It sounds like there's a short somewhere. check your tail light signal and see if you have a bad bulb. Did you have this problem before or after your housing swap?

After the housing swap, but i have the halo's wired into the running lights.....i dont see how the turn signal is affected.

Link to comment
Share on other sites


My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

It sounds like there's a short somewhere. check your tail light signal and see if you have a bad bulb. Did you have this problem before or after your housing swap?

After the housing swap, but i have the halo's wired into the running lights.....i dont see how the turn signal is affected.

I found the problem. One of the butt connectors i used to wire in the balast for the halo let go of the wire and allowed it to grounds itself to the frame of the car, which looks like it just burned the wire back until it didnt touch anymore. I am just absolutely floored that it didnt pop any sort of fuse. All it did was damage one of the elements in the turn signal bulb on that side. I replaced it with another SilverStar and i was on my way. (after fixing the short issue, lol)

Link to comment
Share on other sites

My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

It sounds like there's a short somewhere. check your tail light signal and see if you have a bad bulb. Did you have this problem before or after your housing swap?

After the housing swap, but i have the halo's wired into the running lights.....i dont see how the turn signal is affected.

I found the problem. One of the butt connectors i used to wire in the balast for the halo let go of the wire and allowed it to grounds itself to the frame of the car, which looks like it just burned the wire back until it didnt touch anymore. I am just absolutely floored that it didnt pop any sort of fuse. All it did was damage one of the elements in the turn signal bulb on that side. I replaced it with another SilverStar and i was on my way. (after fixing the short issue, lol)

Glad that was the problem. It's a Lexus. :lol:

Link to comment
Share on other sites

My drivers side turning signal in the headlight is blinking dim and fast, why is this?? Any ideas???

ANYONE??? Its really annoying me, i have a practically new bulb in there. It starts out at the right speed (still blinking dim) and then speeds up. The rear turn signal also speeds up but is not dim.

It sounds like there's a short somewhere. check your tail light signal and see if you have a bad bulb. Did you have this problem before or after your housing swap?

After the housing swap, but i have the halo's wired into the running lights.....i dont see how the turn signal is affected.

I found the problem. One of the butt connectors i used to wire in the balast for the halo let go of the wire and allowed it to grounds itself to the frame of the car, which looks like it just burned the wire back until it didnt touch anymore. I am just absolutely floored that it didnt pop any sort of fuse. All it did was damage one of the elements in the turn signal bulb on that side. I replaced it with another SilverStar and i was on my way. (after fixing the short issue, lol)

Glad that was the problem. It's a Lexus. :lol:

Amen brother B)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership