Sign in to follow this  
brdplya1

Cruise Control

Recommended Posts

my cruise control doesn't work after getting repairs done to replace cam seals and valve cover gasket. The car RPM's ramp up about evry 2-3 minutes. It acts like it going to resume cruise control, then goes back to regular speed and this is without cruise control activated. Any ideas?

Share this post


Link to post
Share on other sites

Hi Playa!

I don't know if th repair was a direct cause of the malfunction with your CC, but here are a couple of other things to check that may lead to another source for the problem:

Does the CC light come on on your dashbaord?

iS YOUR AIRBAG LIGHT ON?

iS YOUR horn working?

If you answered N/Y/N to the above, you'll need to replace the "spiral cable" within the steering wheel - $300.00. The above 3 happened one-after-the-other for me with the CC intermittently going on/off first.

It may also be a fuse. Look in your Owner's manual to find which fuse is for the CC and check it .

Share this post


Link to post
Share on other sites

Definately check the fuse. I have heard (with these cars) that many times this is the problem. Many people do not realize this until they have spent big bucks on other parts first.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this