Do Not Sell My Personal Information Jump to content

Rpm`s Out Of Control


Floridaken
 Share

Recommended Posts

Car type: lexus SC400 1993

Guys, I Just changed an altenator, and thermostat with o ring. after that install, I turn the car on , after it warms up in neutral the idel starts to set between 1000 rpm and 2000 rpm , it goes from low to high every 3 seconds. I dont understand, I took it to the shop , they said it was the mas air flow sensor and it would be $1100.00 retail from lexus, I picked one up off of ebay with the same numbers. put it on, and that is not the problem at all. Any suggestions would be greatly appriciated.

chewin my nails waiting for an answer. :wacko:

Link to comment
Share on other sites

i had a power steering leak cuasing internal leaking of the fuild into the engine .. and then cuase the air control vavle to work properly.. i did cahnge my alternator just like you .. but its becuase ps fuild leaked into it... on neutral my rpm is at 2000, and wont go pass.. its a ari control vavle problem or mas air flow sensor .. just lean the control valve... took it to lexus they estimate 1300 for parts and labor... that is becuase the whole thing cost alot. when they only have to just clean the vavle... instead of cleaning it they wanna make sure it works.. so they jsut install a brand new vavle

open your intake system, and look inside of that chamber, the air control valve is under the traction control box... if its black, dark brown.. or dirty... claen it up.. take the whole thing out and clean it

Link to comment
Share on other sites

i had a power steering leak cuasing internal leaking of the fuild into the engine .. and then cuase the air control vavle to work properly.. i did cahnge my alternator just like you .. but its becuase ps fuild leaked into it... on neutral my rpm is at 2000, and wont go pass.. its a ari control vavle problem or mas air flow sensor .. just lean the control valve... took it to lexus they estimate 1300 for parts and labor... that is becuase the whole thing cost alot. when they only have to just clean the vavle... instead of cleaning it they wanna make sure it works.. so they jsut install a brand new vavle

open your intake system, and look inside of that chamber, the air control valve is under the traction control box... if its black, dark brown.. or dirty... claen it up.. take the whole thing out and clean it

Is your A/C not working? my a/c compressor kicks on and off sometimes and it will change the rpm's by cycling off. Try just turning your whole air system off and see what it does then.

Link to comment
Share on other sites

i had a power steering leak cuasing internal leaking of the fuild into the engine .. and then cuase the air control vavle to work properly.. i did cahnge my alternator just like you .. but its becuase ps fuild leaked into it... on neutral my rpm is at 2000, and wont go pass.. its a ari control vavle problem or mas air flow sensor .. just lean the control valve... took it to lexus they estimate 1300 for parts and labor... that is becuase the whole thing cost alot. when they only have to just clean the vavle... instead of cleaning it they wanna make sure it works.. so they jsut install a brand new vavle

open your intake system, and look inside of that chamber, the air control valve is under the traction control box... if its black, dark brown.. or dirty... claen it up.. take the whole thing out and clean it

Sounds Simular to my symptoms, I will Try the air control valve cleanning. (not the mass air sensor) but the air control valve, it is two different things right? btw thank you..

Link to comment
Share on other sites

i had a power steering leak cuasing internal leaking of the fuild into the engine .. and then cuase the air control vavle to work properly.. i did cahnge my alternator just like you .. but its becuase ps fuild leaked into it... on neutral my rpm is at 2000, and wont go pass.. its a ari control vavle problem or mas air flow sensor .. just lean the control valve... took it to lexus they estimate 1300 for parts and labor... that is becuase the whole thing cost alot. when they only have to just clean the vavle... instead of cleaning it they wanna make sure it works.. so they jsut install a brand new vavle

open your intake system, and look inside of that chamber, the air control valve is under the traction control box... if its black, dark brown.. or dirty... claen it up.. take the whole thing out and clean it

Is your A/C not working? my a/c compressor kicks on and off sometimes and it will change the rpm's by cycling off. Try just turning your whole air system off and see what it does then.

A/C is working fine , just changed compressor also, and had system off .. definitly a sensor of some kind, tps might be suspect also. Thanks again .
Link to comment
Share on other sites


  • 2 weeks later...
Im Not sure , If , U are talking about the Mas Air flow or the Air control valve, Is there such a thing?(air control valve)? I changed the mas air flow sensor between the air cleaner and throttle body.

yeah buddy ,, I changed it.. ohmed it out and it was bad,, so got another one ,, its within range.. but that wasnt the problem.. (even though my other didnt ohm out right, so it needed to be changed) Thanks for the Information and all your help.

Ken

Link to comment
Share on other sites

i had a power steering leak cuasing internal leaking of the fuild into the engine .. and then cuase the air control vavle to work properly.. i did cahnge my alternator just like you .. but its becuase ps fuild leaked into it... on neutral my rpm is at 2000, and wont go pass.. its a ari control vavle problem or mas air flow sensor .. just lean the control valve... took it to lexus they estimate 1300 for parts and labor... that is becuase the whole thing cost alot. when they only have to just clean the vavle... instead of cleaning it they wanna make sure it works.. so they jsut install a brand new vavle

open your intake system, and look inside of that chamber, the air control valve is under the traction control box... if its black, dark brown.. or dirty... claen it up.. take the whole thing out and clean it

looks like it turned out to be a combo of things. mass air flow, ISC, vacume lines from poersteering pump. Thank you for your help..

Ken

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership