Jump to content


Big Electrical Problem


FreddT
 Share

Recommended Posts

I thought I sensed a tiny hesitation upon acceleration in my 94LS with 103 K, so I replaced the plugs and wires a couple of weeks ago. Nothing seemed better or worse upon completion, until today. Suddenly I developed an alarming miss-definitely electrical. After crawling home, I tore open all the plastic covers and such, and couldn't find anything wrong with the new wires or plugs. I drove the car after this inspection, and it was awful.

For the hell of it, I decided to drive the car without the new air filter and the Mass Air Sensor connected. Throttle body wide open. Wow, it ran like a dragster. Yes, the instrument light was on, but there was no hesitation. Really better, with no miss or hesitation of any kind. Never run smoother.

Obvious question-is there a problem with the Sensor? Can I drive without it? I know it's expensive. Can I clean the Sensor? Any other ideas?

Thanks.

Link to comment
Share on other sites


Not sure about the sensor, but I would very highly recommend not to drive it without the air filter. This can cause serious damage to your car. Also, incase of a misfire, the car could catch fire. Not sure about that other sensor though.

Is your car a 91 or a 94? You said 94' but below your name on the left side, it says 91'. Not really a big deal though, as the engines are identical.

Link to comment
Share on other sites

I'm also experiencing the same problem with my 94 LS. I'm still not sure what's causing the problem, but I'm leaning towards a hesitation in Air Flow. Either the ECU can't compute the increase in air when we press the throttle, or the air-fuel ratio has changed.

Link to comment
Share on other sites

I have a 91 and a 94. Love the Lexus. The 94 is actually a relic-used and abused-wife loves it. I figured I can always swap parts? I just took a drive in the '94 with all the plastic covers off the engine, but with the Mass air and the Air filter now installed. Of course, it runs like a top. Really confused, since I didn't do a lot to improve anything.

My next guess is to run the car in the morning when it's cold. Although the problem started after a drive to the Market-after it was warmed up. I'll let you know if I'm stranded. Wife won't be too happy, either....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership