Do Not Sell My Personal Information Jump to content

My 96 Es Keeps Going Hot


Recommended Posts

I have a 96 ES 300 that started overheating the day I had the Power Steering Pressure line replace. I am not really trusting of Shops, but they are a last resort of evil. I told the guys that my car had never run hot before, and that I was 100% this was new and caused by something they had done. They told me in no way shape or form might this have anything to do with the work they have done.

I have also read much post here that say this might have something to do with a connection or a harness. I have checked everything around it and I cannot find anything that seems to be unplugged.

But here is what I am facing.

• Fan Speeds are very low / Never speed up

• When driving on the highway the car temp runs normal.

• Only when stopped at lights is the car running hot.

Any Help with this would do.

Link to post
Share on other sites

I have a 96 ES 300 that started overheating the day I had the Power Steering Pressure line replace. I am not really trusting of Shops, but they are a last resort of evil. I told the guys that my car had never run hot before, and that I was 100% this was new and caused by something they had done. They told me in no way shape or form might this have anything to do with the work they have done.

I have also read much post here that say this might have something to do with a connection or a harness. I have checked everything around it and I cannot find anything that seems to be unplugged.

But here is what I am facing.

• Fan Speeds are very low / Never speed up

• When driving on the highway the car temp runs normal.

• Only when stopped at lights is the car running hot.

Any Help with this would do.

i think your problem could be that the mechanic maybe disconnected a wiring loom and possibly this has not been put back correctly, it seems if your car is okay while running on the highway but over heats while city driving your electric fan could be not running due to the wiring harness connection problem,

let your car idle over in your driveway and see if the electric fan comes on,this should activate while you are sitting in your driveway with no air being pushed through the radiator, give it 5mins or so to get some heat into the motor, also then try turning on the air cond this should kick in the other fan straight away.

fergi

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...