Sign in to follow this  
lexie98

Gs300 Ac Problem

Recommended Posts

i have a 98 Gs300, and the air has stopped blowing. i have the touch nav screen, and the buttons change and work, but nothing blows out of the vents. someone said it was the climate control module, but im not sure. so if anyone has any ideas or insight i would appreciate the help.

Share this post


Link to post
Share on other sites

It could be a number of things... The first thing to check would be to check your fuses and the terminal plug that powers the blower motor. If the fuses are good and there is 12V at the plug, then your blower motor is most likely bad. Jump 12V to the motor itself to make sure. After you do that, then you check the climate control module. Let me know what happens.

Share this post


Link to post
Share on other sites

It could be a number of things... The first thing to check would be to check your fuses and the terminal plug that powers the blower motor. If the fuses are good and there is 12V at the plug, then your blower motor is most likely bad. Jump 12V to the motor itself to make sure. After you do that, then you check the climate control module. Let me know what happens.

thank you. i really appreciate it, ill check it tomorrow. hopefully its something simple.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this