Sign in to follow this  
windy

2000 Es 300 Problem

Recommended Posts

I posted a problem earlier today. However, one other problem is that when it does not crank properly, it idles rough, especially if the air conditioner is running. Also, if I'm accelerating down the road, say around 50mph,the motor will hesitate and the rpms will drop. When I accelerate just a little, it will come back to normal. I have already put a throttle position control, new spark plubs, air idle control and had my muffler replaced. No codes show up when the motor has been checked. Also, my check engine light has never come on. Still needing help.

Share this post


Link to post
Share on other sites

I posted a problem earlier today. However, one other problem is that when it does not crank properly, it idles rough, especially if the air conditioner is running. Also, if I'm accelerating down the road, say around 50mph,the motor will hesitate and the rpms will drop. When I accelerate just a little, it will come back to normal. I have already put a throttle position control, new spark plubs, air idle control and had my muffler replaced. No codes show up when the motor has been checked. Also, my check engine light has never come on. Still needing help.

I do have the same model car 2000 ES300 wife loves driving this car everyday. We also own a home in Gulfport MS. Here is a link that could help you http://us.lexusownersclub.com/forums/index.php?showtopic=30723&hl=IACV

Share this post


Link to post
Share on other sites

Thanks so much. The website you sent was very helpful. I also love my car, even though it is 10 years old!

I posted a problem earlier today. However, one other problem is that when it does not crank properly, it idles rough, especially if the air conditioner is running. Also, if I'm accelerating down the road, say around 50mph,the motor will hesitate and the rpms will drop. When I accelerate just a little, it will come back to normal. I have already put a throttle position control, new spark plubs, air idle control and had my muffler replaced. No codes show up when the motor has been checked. Also, my check engine light has never come on. Still needing help.

I do have the same model car 2000 ES300 wife loves driving this car everyday. We also own a home in Gulfport MS. Here is a link that could help you http://us.lexusownersclub.com/forums/index.php?showtopic=30723&hl=IACV

T

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this