Do Not Sell My Personal Information Jump to content

Brake Lights Not Working


Recommended Posts

1999 RX300 - Brake lights will not come on, but tail lights work. Replaced all 5 bulbs (including middle "third" light), replaced stop light fuse, replaced stop light switch on brake pedal. What am I missing? Is there a relay involved? I seem to remember hearing a "click" sound under the dash when I pressed the brake pedal in the past (I may be confusing this with my other vehicle, Tundra). I don't hear it now.

Link to post
Share on other sites
1999 RX300 - Brake lights will not come on, but tail lights work. Replaced all 5 bulbs (including middle "third" light), replaced stop light fuse, replaced stop light switch on brake pedal. What am I missing? Is there a relay involved? I seem to remember hearing a "click" sound under the dash when I pressed the brake pedal in the past (I may be confusing this with my other vehicle, Tundra). I don't hear it now.

Sounds like your brake light switch.Not exactly sure where it`s located though. Might want to inspect under dash,by the brake pedal.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...