AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.




Neofate

Regular Member
  • Content count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Neofate

  • Rank
    New Club Member

Contact Methods

  • First Name
    J

Profile Information

  • Lexus Model
    2015 ES 350
  • Lexus Year
    2015
  1. Thanks for responding, been waiting on this. It's still getting that 17-18 mpg -- Any ideas on what to do to improve it? Driving like a granny, very slow acceleration,.. etc. Only time it picks up MPG is when on highway at like 70+ mph really. Lexus told me to put 87 octane in -- Would that cause the MPG problem? Does it need 91? higher? It's bumper to bumper warranty -- So, any things that need to be checked/changed whatever if I can prove/find them can be done for free by Lexus - but this sub 20mpg average just doesn't feel right for this car on constant ECO being driven as delicate as humanely possible. I'm even popping in neutral down hills while watching gauge sometimes. Which shouldn't be necessary of course. I figured some others may have some ideas, tips -- Anyone have anything to contribute? Thanks,
  2. Hey guys, I searched but found nothing to answer my question about my 2015 ES 350 I just bought. I bought this a few weeks ago,.. 2015 Lexus ES 350 with 17k Miles -- I've been monitoring the in car fuel economy computer and trying different things. I average about 17-18mpg. It's driven 'light' -- As I'm obviously trying to maximize the mpg right now as it seems low esp. with regulations and so on. I don't expect 35mpg or anything,.. but I have a 2008 350Z which I've added 100hp to and I get better fuel economy with that sportscar than this Sedan? I don't get it to be perfectly honest. Is this just the way it is? Normal? Or what do you guys get from your 2015 (or that same engine anyhow) fuel economy on ES 350's? I've kept it in ECO,.. tried all the modes and honestly the fuel economy doesn't seem to really change any despite mode -- which I found odd. Even when I drive it ridiculously.. like popping in neutral (it's an auto of course) down long hills.. being mindful of accelerator from red light, up hills, coasting as much as possible and so on -- it doesn't pop up to 25 or 30mpg on the meter or over X dozen, or hundred miles. The average over last 3 weeks of about 500-600 miles has been 17-18mpg of granny driving in ECO mode. So if this seems definitely abnormally low for ECO Mode: What is normal range for City, but driving very non aggressively, driving on average? As it has a bumper to bumper of course.. if something is off, I'd like to figure it out to some degree before bringing it in and just complaining about fuel economy :) My last Lexus was an RX 330 -- and it got horrid fuel economy.. 12-14 mpg it seemed.. I just attributed that to weight of SUV and being in full time 4WD etc.. This is different and has the Normal, Sports, and ECO(nomy) modes -- so I'd expect something more around 24-25mpg average with 'granny' driving around the suburbs if you will. If 17-18 ish mpg is normal.. then so be it. Thanks!
  3. Sorry to bring this topic from the dead -- But I'm curious about the 1994 LS400's with the Pioneer sound system in them. It has a trunk mounted 6disc changer, with the remote inside the console. It has a tape player and radio on the head unit. All speakers work, and it sounds fairly good. I see sub's mentioned here in the LS400 of this year range. It surely doesn't sound like this car has any sort of sub in it,.. Does it not? If it does,.. what size and where is it located? If it doesn't -- Can I put in a sub for realtively cheap to give this car a little bump on the sound? If so, where do the factory subs mount? Are they enclosed or free air? Any information on this would be very helpful. I am just trying to get my sound system a few notches better than it is currently, but not be bumping down the road with 12 or 15 inch subs with 1000's of watts of power. Something simple , just a slight upgrade in sound quality/bass is what I'm after. Ideas? -- Info? Thanks !
  4. Hey guys -- I am to pick up my 1994 LS400 from the shop Wednesday or so this week. It has the factory 'Pioneer' head unit. No nakam... But it still sounds pretty good stock. My last sytem I built when I was 16 -- and kept it for 3-4yrs. This was about 10yrs ago. At that time, I went with very good brands on all equipment.. though it has been a decade so I am unsure if these brands still are made, and if they are still 'good'. The system I had was a custom box, no port holes. With two JL Audio 12" Subs, (JLW6) versions, as oppossed to the W1's, and I believe they had a midgrade W3.. been a while. (Basically higher RMS, and a much bigger magnet). I amped the 12's with two Kenwood amps, each put out a very clean low distortion ratio 100Watts "RMS". The bass from this system was surprisingly freakish. It was clean, and sounded better than 90% of the systems I came across. People always asked me what I did to get the sound I did for such low wattage, etc. Bottom line reason this sounded so good, and clean, and produced the DB's it did was because it was rear mounted in my 1991 300ZX. The hatchback in that car made the accoustics for the subs perfect. IE: If this same sub setup was put in a trunk of another car it wouldn't sound nearly as good.. etc. I left the rears stock.. I believe I didn't even have them operational. It was a 2-seater, so that wasn't really necessary. I bought a mid-grade Kenwood CD player for the head unit. Then the Mid's were 6 1/2 MBQUARTS. (These were the top of the line Mid's at the time ) -- At the time I got them for a deal, but even at that the pair was $350. Built in crossovers, etc. Each of the MB Quart 6 1/2 mids were mounted in each door kick panel. They took 75Watts a piece RMS. (Nearly the amount the subs pulled). I used a single kenwood, 150Watt amped bridged/split to run 75Wx2 to these two mids. Again, low THD. I also added a relaltively inexpensive 120$ crossover, and dialed the subs down to a very, very low cross over point to not pick up any of the mids and definitely no highs. I also cut the mids off at a certain point up the spectrum as well. It as dialed in well.. Used 4 Gauge cable to power the Amps. (little overkill, but my friend worked in the install shop). Anyhow -- So the brands we are talking about then were Kenwood for Head unit and amps. MB Qaurt for Mids, and JL Audio for the Subs. Simple setup, but very very impressive and clean. Now.. As I said the stock system in this 94 LS400 sounds decent.. Speakers aren't blown or distorted, and all work. However, I'd like to give it a little punch. Nothing like I had.. I don't want 2 12's riding down the street setting off car alarms as I go through a parking deck. I'd like to be subtle. I was thinking either a single 8" woofer/sub, or 10" woofer/sub. I'm debating if I went with an 8" sub, just for a little kick.. if maybe it would not over power the factory speakers and it would just give the sound I am after. However, If I do need to go ahead and throw in new speakers all the way around.. I will. If I am to do that, I suppose I will be going with a replacement headunit as well. Now, the factory headunit is double DIN (very large). Is it relatively simple to purchase a head unit that will fit that large slot these days? I still have the MB Quarts from the first system.. They are 6 1/2'" mids. Is that size possible to use in the front or rear of the LS400? Or are they just of no use? Basically I want a clean, rock punch. Something responsive -- The 8 or 10 just to give the bass, but punchy clean bass. Fast response time that can keep up with bands like Chevelle, or slipknot. I do not want the 'Boooom Booooom' laggy over powering bass I did when I was a kid. Nor do I need a 100+ dB system. I'll crank it up to show off a little to a friend every now and then, but I'll keep it at a reasonable level most of the time for normal listening. So if you had a customer (or were me).. and wanted to get out as cheap as possible, but with good clean sound.. just a few steps up from factory. What approach would you use? IE: Give me some example systems -- Say I would keep your factory speakers, and go with this 8" sub that is X RMS, and grab this amp. You should be pleased with it. Or Go ahead and grab this series of speakers from X company. They are X RMS -- (Your head unit should power them just fine if you use X headunit) -- Grab this 8 or 10 inch sub (brand/model), and this amp at X RMS. You get the idea. I'm not looking to spend a fortune here either.. If I could get out with like 500-700$ that would be ideal. I'm not looking to spend 1500+$ on a system. An absolute must: The bass will have to be trunk mounted I know (the sub) -- I do not want a rattling trunk at all. So if that dictates the size and power of the sub, then so be it. I just want a bit of punch, without boom rattling the trunk to death. Ideas? I don't have to have the fanciest headunit either.. Just a decent brand, that plays single disc CD, radio, and MP3 compatibility. I don't need a fancy pop out LCD screen etc. Just something that fits the slot nicely, and can play the CD's/Radio etc. Something has to be possible even in such a tight budget. So you audiophiles help me out here :) Thanks so much
  5. Ls'92 Strange Vibration At Speed :))

    Good advice. I don't know the condition of her Caliper, can only go by what is told. I've experienced a caliper 'locking or seizing' and it shattered the Wheel into pieces (alloy), and would have been a nasty wreck if I wasn't simply pulling onto a somewhat unbusy road at the time. This is the only reason I mentioned if it 'could' be a potentially dangerous caliper, it would, obviously, be wise to get it taken care of. If it is just locked tighter than the others then it is a different story, but anything is possible. It is my understanding that vibration of the type spoken in this thread is generally not considered generated from brake components, but vibrations are resonated from brakes all the time. (Vibrations while you are *not* braking, eminating from the brakes.. are not common.) I agree with you on the CV vs U Joints. CV joints are more expensive because of their more robust design, they are a different joint (in my understanding ) than U joints entirely. Engineering wise. As for motor mounts -- All I know is what a mechanic that I respect has told me,.. That on a somewhat higher milage car, new motor mounts will generally always make a marked improvement. *Though not to say this is your problem* I tend to think this is eminating from your driveshaft as well, or a component that is directly connected to it in some manner. The specific described vibrations just scream , hey check around the drive shaft. ;) Best of luck.. and let us know what ends up being the resolution.
  6. Ls'92 Strange Vibration At Speed :))

    Well it sounds like I was in the right ballpark -- With Rotors and the Joints have an effect on the driveshaft.. good information. The only way I could possibly fathom a single caliper, and only ONE caliper becoming considerably hotter than the others on a consistent basis is improper function (obviously),.. more specifically it is locking up. When you apply the breaks it doesn't fully release that caliper, thus you get a vibration generating from the caliper that is still apply some resistance to that rotor, connected to that axle, connected to the hip bone, which is conencted ;) -- You get the idea. But, the experts here think it is likely a dual problem. Calipers aren't fun to buy -- But, if a caliper COMPLETELY seizes on you, it can and usually does cause a wreck, especially at 100Kph. I would have this examined and tested, if not just replaced for the safety aspect. Your life isn't worth trying to make sure you don't 'waste' money on a caliper. You could always grab a used caliper from a junkyard or refurbished caliper -- Should work just as good as new, and not cost you an arm and a leg. Depends on where you take it,.. a good , friendly, indie can replace your motor and trans mounts quickly, and for under 200$ if they are nice, a bit more if they mark up labor and parts more -- Not sure where lexus would go with this. Tires,.. obviously non labor intensive, can be done in minutes literally.. likely a 15-1hour wait.. unless you just get it all done at once (best option). Now the Constant Velocity joint (Lexus uses these? Fantastic.. I thought it was just a U joint for the RWD.. but again I'm not well versed on these cars yet) -- Anyhow.. this joint is expensive (to me).. new. From other vehicles I remember they run about $500.00 new from a dealer. Though, getting a rebuilt unit can cost considerably less, and I wouldn't dissaprove of it. If you have the money, go with the cheapest 'new' joint you can -- But if your running tight on money, a rebuilt unit (imho) will do just fine. The labor, as you asked, is not intensive (relatively). Think of a bad CV joint as a popping sound if the outer portion is bad, and a pluuuning sound if the inner core is bad. They last anywhere from 10-15yrs before you really need to get them changed out.
  7. Ls'92 Strange Vibration At Speed :))

    Driveline u-joints. I'm sure you've gotten this answer -- but I'm just going off your main post, and the reply. If it is your U-Joints, you jumped from A to Z in a genius way !.. First off -- At that speed I a few things come to mind,.. Every describes problems differently so need to list them all. A) Wheel Balance -- (Cheap, be an easy check) -- B) Rotors,.. Warped rotors are a definite cause of break stutter -- Though if the stutter only occurs at that speed, it does make this a unique problem. Still wouldn't hurt to pop the wheels off and and Mic them. C) Driveshaft -- Considering the location you are describing,.. any considerable imperfections/warps or loose parts in the driveshaft can cause similar symptoms. I'll hush now, and go read the rest of the posts that probably have already answered this problem in detail :)
  8. Will Not Start

    Sorry my ideas are only coming form my Muscle car knowledge, mainly Mustang's -- I have just purchased my first lexus. But as for MAS, does that by any change stand for Mass Air Sensor. I wouldn't imagine it would because that was old technology in the mid/late 80's for 5.0 Foxbody's. Anyhow -- No wait that is the Modulated Air Suspension,.. hrmm.. The only idea that popped in my mind for the code would be to pull your 20amp EFI fuse for 30 seconds, with ignition off. That resets your computer/codes, without resetting clocks/settings and whatnot. But it doesn't sound like the status of the code message is your main problem here. Just to be clear -- will the car not start, or just your Suspension not operate properly? If the engine won't turn over for any length of time it makes it hard to generate any codes. I'm of no use to you anyway ;) -- I'm sorry, I have a ways to go before my terminolgy can be of assistance to the technical users of this brand of car. Though maybe I am the only one, but it might help to verify if it is your suspension having problems, or the car/engine itself not running and a MAS error code is showing up (and thats the only reported code) Good luck,
  9. Bought '94 Ls400

    No need to stand corrected.. :) -- I'm long winded in my posts, so I expect people to skim them at best.. hehe. I can't wait to post the pictures to be honest. I'm actually looking FORWARD to washing and waxing the car. Because its already in good condition now, so washing a clean car is not a 'bad' job. However, once this 240 is sold.. I will have $1600 to 'play with' -- It is my mini Lexus fund. Some inital thoughts are: A) Sock back $200 for instrument cluster that is bound to go out eventually. B) Use $200 for a tint job C) Use a few hundred for a decent head-unit (cdplayer/mp3player/ etc) I'm not real sure -- I've been browsing around the forums, but it isn't like the mustang enthusiasts :) - Where you had a kajillion parts to choose from ranging from 20$ to 2000$, that you could plan an entire 'upgrade' around. But I suppose there are alot of parts, but I don't want to take the 'stock' look out of it, nor change the ride. Though 'bettering' it wouldn't bother me at all.. What are some common enthusiast upgrades, that are easy on the wallet when they first start 'modding' the car if you will. (I consider different headlight bulbs a mod, so it can be anything ) :)
  10. Bought '94 Ls400

    Judging by what you've heard and seen, I think you just might know how much oomph your car has,.. you just choose not to use it :) Well the instrument cluster is actually fine -- All the lights illuminate properly, yes,.. The only problem with it is the Fuel gauge stopped working, the needle stays down. (Though he said it is working now after he pulled it out to see which end the problem was on) -- And said he found a guy who would fix the cluster for I believe $195 -- I said nah, let's pass on that, and I can work that out later. The fuel gauge is 'temporarily' working atm, it could not be workign again when I pick it up, but the low fuel light comes on, and he said his wife always reset the tripometer, and it refueled at 350miles. So I'll just go by that if it decides to quit working again. Then send it off for repair at a later date. (Just on that note.. can I get him to take it out later on, and continue to drive the car without the cluster in until it is shipped back?) -- I've been driving a car for years that the speedometer doesn't work in.. I don't need the instrumentation to drive.. (temporarily of course). Also, the guy who rebuilds them here.. are prices any better than the 195$ I was quoted? -- The main problem as I have mentioned several times now is that darn LCD blackout 'smear' on the Climate Control.. He has it out and ready for a new LCD panel to go in right now.. Cept, well, we don't have an LCD panel. I am hoping the part can somehow be shipped overnight from California to get here Thurs/Fri for him to have it all back together Sat Afternoon. *I am selling my current automobile Saturday as well.. so of course getting all transactions and such done in one day saves alot of hassle, and having my new 'baby' would be nice to show off and enjoy. ------------ I think the first thing I am going to do to it is take it and get a CD player installed (providing the 6 disc in trunk doesn't work) -- and get the windows tinted a bit. Nothing ugly.. just to make it look a little sharper. I'm used to tint, and Black tint on silver should look pretty sharp imo. Lowest legal amount I think is 35%, so I would probably get that. -- Been a while since I've had windows tinted,.. anyone have a ballpark figure for about what that runs these days? I had a friend who worked for Novus do a 2-seater for 100$ cash on a Saturday once, but that was a steal. I'm thinking around $200 or so for the Lexus? Thanks..
  11. Bought '94 Ls400

    No, unfortunately, it is a Pioneer. (Never thought I would say unfortunately about a Pioneer sound system, heh). Though it sounds good for being so old. I used to be a big audio nut (car audio specifically), and had amps, subs, mids/highs coming out my ears. So I did instinctively test each speaker the first time I saw the car. All working :) When I took it out for the test drive, I tuned it to a decently received radio station and adjusted the Bass/Mid/Treb to my preference, and it sounded surprisingly good. It has a 6disc change in the trunk, though it is missing the front door cover, but he says he thinks it still works. I'm not going to ask him to fiddle with the 6 disc changer after all of this, I could have the thing in the shop from now till kingdom come :) -- I anticipate I am going to do something about the CDplayer situation soon after it is in my hands though. If the 6disc works, I will , of course, continue to utilize it. But if it decides it has had enough, I might end up getting the radio yanked (radio/tape player combo) and put in a semi-decent head unit. Depending on prices these days I miiight throw in an 8 or 10inch sub.. But I'm not as crazy as I once was. :) You see you think like me,.. I think I'm getting an excellent deal. I think I'm basically getting a 4500 lexus and whole TON of mechanical labor done for free. Sort of like I went and bought the lexus from someone else and brought it to the mechanic and said fix anything that needs it. -- Again it is the whole LCD Climate control deal that is holding things up. I contacted the guy via email a few hours ago who sales the replacement LCD pieces you solder in for 160$ + shipping.. And explained who I was, and the situation,.. and that if my mechanic contacted him could he please let him know I am willing to pay for the speedy shipping and so forth. I can't imagine there is a whole lot of 'business's' or 'people' who are building LS400 90-94 LCD replacements, so that is probably the same 'email' my mechanic has. Hopefully when they get into contact he will be able to get the part quickly. However, if it is.. That is alot more than I anticipated he was going to have to pay to for the part for the climate control. $160 is not chump change, for a little LCD display.. and that is coming out of his pocket , not mine. Maybe he found a cheaper way,.. I'm not sure. Take care,
  12. Hey guys, My mechanic has my LS400, and is struggling on getting the part(s) to fix the Climate Control's LCD. It has that blackenned effect to it now.. like the LCD has smeared inside the panel. He says he has the email for a guy in California, but so far he hasn't even emailed the guy, and said the part would take 2-3 days to arrive because it is coming from California (I am located in B'ham, Alabama). Since this is a relatively common problem, I figured one of you might know where to hook me (and indirectly him) up with a part vendor for this? So that we could order it tommorow, and have it shipped overnight so he could get it fixed and I could get my baby back this week instead of next week. There is bound to be more than one guy with an email address who has these parts for people to fix this problem themselves. (He knows how to fix it, he just needs some parts.. though I would have to ask him which parts.. but I'm sure you guys know what parts I am speaking of based on the description) Again it is a 1994, LS400 -- Blackenned out LCD display on the Climate control area. You can post here with a response or send me a direct email at jaredguess@gmail.com It would be very much appreciated. Thank you,
  13. Bought '94 Ls400

    Thanks.. yes, all this is being done prior to the sale. I've put $500 down in earnest so it is going to me.. but the hold up from me actually driving the car now is he is busy doing all of this stuff as 'part of the deal'. As for the other items you mentioned. I guess you misssed it: But at 190,000 miles he replaced all major items in the engine. The timing belt, seals, etc. So the timing belt has 30k on it. The water pump has a little less than 30k. Alternator was done in 06, .. Basically the only thing that isn't fixed or replaced is the block itself. He said at the very minimum I wouldn't have to do any maintenance other than brakes and tires for 60,000 miles... and even then it will probably go 90k without any major service, but it would be wise to go ahead and do recommended service at that interval if I wanted to keep it in the shape it is in now. I will definitely post pics, I'm proud of this car, which is why I can't wait to get it,.. wish he would hurry up already ;) The only thing holding him up is one part. He needs the part to fix the Climate control LCD display. He said the part will be coming from California and he has the email address of a guy who has the part, and it would take 2-3 days to ship from California. I left him a message tonight saying I would pay for overnight shipping of that part if he would go ahead and get that guy to ship it over tommorow, so we can get this wrapped up and in my hands Saturday. So, on that note: -- If you or anyone else knows of a place, guy, dealer etc that sales the parts for the 'blackenned LCD' problems for the climate control section of the LS400's please let me know asap. I could put him in contact with whomever you guys know so maybe we can get this part out here by , say, Thursday (shipped overnight) and he could finish things up.. instead of having to wait until next week for some electrical part to come in from California that isn't ordered yet. I know it is a common problem, so maybe someone knows who to hook me up with. Thanks!
  14. Bought '94 Ls400

    Hi, I recently bought a LS400 with 228,000 Miles for $4500. I usually would have not even flinched at a car with those kind of miles but I know about these cars. So I took a look at it. Long story short, for a 1994, LS400 with over 200k, it is immaculate. The paint looks brand new. (Been garage kept). Out of all the people in the world to own it, an ASE certified Master Mechanic. Now that doesn't mean the car was great, but could be a good sign. It is champagne (silverish color), with tan/brown leather interior. At first glance here is the laundry list: Climate control is blackening. -- (He is fixing that this week.. having to wait on a part from the West though) Fuel Gauge in the Instrument Cluster was at the bottom -- (Says he has it working now from examining it, but it isn't likely to stay working, and found a guy in ND or Canada) that will fix them for $195. (Is there any better option than $195 for my fuel gauge if it is definitely caused by the intrument cluster? No CD player in dash, so I looked in trunk. 5-6 Disc change in trunk, though the magazine wasn't in it, and it looked like it had been banged by something. He said he thinks it still works, he will get the magazine. (Not a deal breaker of course). This was wired to the console (between the seats) when you lift it up there is a hand held controller to select song/disc, etc. This powers up. The leather looks great,.. no holds or anything, but it has these streaks in it between the main creases.. of a lighter color. Almost like they could be rubbed out. (Remember this is a Tan/Brown leather). -- Is there any product or method to smooth the color of these streaks? This would really make the seats look good, but they are in good condition even the way they are. Everything electrical works, seats, steering wheel, radio, AC/Heat, climate control, windows, every button I could find and press (sunroof, etc). So I take it out for a test drive. Its smooth, great, has the lexus ride. Runs fine around the neighborhood, so I got it out on a faster artery.. about 40-50mph. Good, but no room to speed it up.. So then take it on to a major highway/interstate. I at first, stayed around 60/65 mph and just cruised. I would press the "overdrive" button in and out to test its function. Yup, it dropped it from 5th to 4th gear. (or perhaps 4th to 3rd, whatever the top gear in those cars is). Also it has an ETC/Power button. I then switched that out. Couldn't tell a difference while driving normally. So I decided it was time to test it a little harsher. I would slow down in the left lane, to about 45mph.. Then get on the gas till about 85-90mph. (It doesn't take long). I might let it ride at 80Mph for a minute then back down to 65-70 for 'cops sake'. I kept slowing down and gunning it, it is smooth. Is this how they are supposed to act? When you push the gas in it can swap one or two gears. (at these speeds) -- If it drops one you get a modest pickup in speed, but if you press it in slightly further it drops one more, and it goes like a bat out of hell. (I could tell, I think, that with the power mode engaged it would more quickly switch to the 'bat out of hell' mode. (As if it was more sensitive to the faster down gearing with the power button selected'. I rolled down the windows, had everything off,.. No sign of detonation/pinging, or even suspension trouble. (To note: My father has a 1999 LS 400 with 120k on it, and I rode with him over there. So I had an immediate comparison to judge it by.) To drive both cars you wouldn't know which one was which with your eyes closed. To the guts: The mechanic said he had done a major maintenance at 190,000. Which included, but not limited to: Pulling the engine (He said he wish all cars made their engines like lexus, as I inquird how difficult it must have been to pull the engine in such a sophisticated car,.. he said it was the easiest he had ever done) -- Anyhow,.. With the engine pulled: A) Changed the timing belt. B) Replaced wear and tear seals C) New Water Pump D) New alternator E) Oil/filter, and other recommended maintenance .. I honestly can't remember it all. Between then and 220k, he has put a new battery in it, and he said he changes the oil with only lexus parts (filters) and only uses lexus parts for any maintenance. Good to know. What he is doing this week.. (I am so anxious to pick the car up, but he promised to do some thing before I got it) The power steering is slightly leaking (he had to tell me that, I couldn't tell) -- So he is putting in a new rack and pinion. Said if that doesn't stop the leak, he will continue until he fixes it. -- Ok great. Fixing the LCD blackening problem (he has it out in pieces now, says he is waiting on that part) --says that will take at least until Saturday and maybe longer-- Fixing a sensor on the rear passenger window .. the window sometimes won't respond to the driver side button to roll up,.. (he said its a bad contact) Putting in new motor mounts (and tranny mount) -- He mentioned this would make it ride alot better.. even though it rides fine imo.. but I can imagine at these miles it wouldn't hurt. Finally changing the oil and filter -- (This is where he said he would only use a lexus filter) -- I mentioned something like do you mind changing the oil/filter.. you can use anything here from the shop, and he said oh no.. I only use Lexus parts, even the oil filter. (Basically while he has it, he is going to do it right.) -- Which I respect and will follow. I'm not bragging here by any means,.. Just curious based on description , this sounds like a really good car and decent deal.. right? The only thing that might move the price up a hundred or two are the motor mounts.. that was not part of the original price deal. So it might be 4700$ in total. I have a down payment now, and he gets the rest of the money when I pick it up. He said yesterday that at worst all would be done Saturday 'minus the climate control blacken' -- I would think that part could be shipped overnight/2day and he could get that done between now and Saturday. The hardest thing, to me, would be doing the rack and pinion -- But when I mention that he say ooooh no.. That is the easiest thing, I can knock that out in no time flat. He's the mechanic, not me.. and he has obviously had this car in a zillion pieces more times than I know.. So he knows how it works and what takes a while. Oh forgot to mention he resurfaced the rotors, but left original pads on. So brakes are smooth, but pads probably have 30-40% life left on them. Tires are good, but again, are now new. I'd guess 10-15k left on the tires. Any thoughts? Any things I should ask, and look out for? Any ideas on that instrument cluster fuel gauge? Any ideas on the leather seats I mentioned? *I also have a buyer for my car who wants to come asap to pick it up, so I'm holding him off while waiting on this car to be ready* -- I don't want to rush the mechanic but I also would like to have the car by no later than this Saturday. Based on what I've said, that is doable, no? *He has his own shop* The car was listed for sale in the paper 2.5 weeks ago, and I made initial contact 2 weeks ago, and put the down payment down last Thursday. So expecting the car this coming up weekend isn't unreasonable.. or is it? Thanks for any advice you can give me.. (I love the way this thing looks and especially rides.) -- So you can imagine my want to get out of my current jalopy of a car and into this smooth machine. (I'm selling my old car for $1500 -- Its a 240sx, in decent condition, but I'm getting rid of it). Thanks again!