AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


renphilia

Regular Member
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About renphilia

  • Rank
    New Club Member

Contact Methods

  • First Name
    kevin

Profile Information

  • Lexus Model
    RX300
  • Lexus Year
    2001
  • Location
    Other / Non-US
  1. So is it not transmission related ? Actually I cleaned the throttle body last week. But I didn't clean the IACV as it was a real challenge to remove those 2 pieces factory tighten screws. So I just sprayed some bits though the small hole underneath the right throttle (I thought that might help cleaning the IACV)
  2. Hey everyone. I am beginning to experience random "thomp" with my 2001 AWD RX300. Currently it's still on 140k miles. It randomly happens whenever I release the accelerator pedal for few seconds, then depress it back in a hurry, the RX would lunge with "thomp" sound. I am not sure what might be the cause but nowadays I try to control my feet as whenever I release the pedal, I try to depress it back slowly until the RPM gauge "reads" my feet and I can depress it deeper normally as usual. Not sure whether that really solved it or just minimize the "thomp" till as if it doesn't occur. Is there any thought on what could be the cause ?I thank you for everyone's idea here..
  3. Hi everyone, sorry for bringing up this old thread. but I would like to ask for advice/suggestion, as my 2001 RX300 AWD now runs on (I think) regular T-IV equivalent ATF (which I have to add/topup once in 2 weeks, doesn't smell burnt though). Reading all these posts in this thread makes me want to switch to this Amsoil product. Sometimes my RX just downshifts too fast/suddenly (especially after a 90 degrees turning)the moment I release the acceleration pedal.It still shifts fine though. So my question is, how should I start from here on? can I just switch it directly to the Amsoil product during my next drain-and-fill ? or do I have to flush out the old fluid and replace it ? Which Amsoil transmission product is recommended ? I've seen the Signature series and the OE ATF..truck is now on 145k miles. Everyone's advice n suggestion would be greatly appreciated.
  4. I am not sure as what do you mean by Canadian model. Afaik there are only 2 types of model: the Japanese version (JDM), and the one sold for the US market. Maybe it's differed by which side the car drives (RHD/LHD). As for me, even though I am living outside US/Europe, I have the standard JDM version without navigation and it is an All Wheel Drive (AWD). I also have that transfer case with that unique fluid. Since you mentioned transmission, I would say mine is definitely U140F
  5. Yeah. here it is then: http://us.lexusownersclub.com/forums/topic/90568-my-01-rx300-treatment/ Let's keep this clean as transmission problem/symptoms related forum :)
  6. -> I tried polishing them already. well it looks like only the right side is still white-ish, while the other side has been quite oxidized (dark appearance). I could see it is actually white light during night time outside the vehicle. But it seems a bit yellowish once you are inside and take it for few rounds. As you mentioned, I used plastic polish. -> When I bought off the car, it wasn't originally came pre-installed within. I had to install it by ourselves. Went to independent CNG workshop and have it installed.around $1068 including labor. came with 1 year kit warranty. To be honest, you could see many taxis, even private cars using CNG considering the hikes on gasoline right now here (gas price is updated weekly on Wednesday here. -> Guess I mistook AWD -> 4WD. Mine's AWD then. Transmission is U140F. -> i had it taken to workshop once, was told by the mechanic power steering fluid..which was due to my failing return hose. not sure about leaks. But right now I do have to check the ATF level i.e every 2 weeks or so, topup about 1.8-2 liters (2.1 quarts in US standard). Weird enough, couldn't locate any ATF dripping. Or did it travel somewhere else ? Or this is normal actually ? Oh I'll be sure to clean her throughly before letting her sleep in my mechanic workshops. Planned to have major service on her (leaks, drippings, airflow sensors, etc) as well as have her mount struts changed if required. althought I recenty finished cleaning the throttle body by myself. P.S the IACV screws were hard to come off. Untill now I still haven't been able to open them. Seems legit enough for such factory locked screws
  7. pardon the birds though, they loved the RX too much i guess. 2001 RX300. she shows 138K miles. but I am guessing it had been reset. and should be around 240K miles by now. everything's stock except she was already installed aftermarket single din unit below the center compartment. 'P' and 'D' light were already gone. overall, a very nice ride. just that I need to get her cleaned. oh yeah, temperature control does not change although it is adjustable. transmission..hmm..there's a slight less than 2 seconds delay when trying to get her run everytime in the morning. the moment I put 'D' from 'R', maybe.. a sec I am guessing. not that it bothers me as long as the transmission is in great condition. mine is AWD. and it is running CNG. well at times I have to check the transmission fluid level and top up if necessary. there shouldn't be anything wrong yet, right ? about the gear oil seeping out..how do I look for it ? I am a complete amateur and noob at this DIY stuff.. but probably some informative and beginner links about Howto would be helping. I am used to checking fluid level, changing wiper blade, disconnecting battery terminal (as well replacing it), replacing relays in the fuse box, engine oil and coolant before travelling(add more should it were insufficient). just some minor check and preparation, and simple maintenance.
  8. Hello all. I am a new member here. Just finished registering, and hope to get useful advice/information, as well as to provide useful feedback/suggestion to all first gen RX300 owners here. Actually I feel like I am taking a gamble, as I have decided to get a used RX300 (well it's Toyota Harrier here) even after seeing so many negative comments, and especially issues about the transmission failing. 16+ years old vehicle to be precise. I believe although the one I am getting isn't exactly a Lexus, but it shares the same spareparts, especially engine and transmission same as the ones in RX300, though mine doesn't have the heated seat and cruise control. and to be honest, I wanted this beast to last until my marriage and my first child in the future. So, hope to get along with everyone here. And yeah, the one I am buying is 3.0 V6 engine.