Do Not Sell My Personal Information Jump to content

meg01

Regular Member
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by meg01

  1. this is my first post: I bought my 94 LS 400 in Aug. 07, so i've only had it a few months. shortly after i bought it, it began making a faint whining noise. in my experience with cars, i know this to mean it's getting low on PS fluid, so I checked it. it was fine. very quickly, the noise began to get worse, so I took it to a shop to have them listen to it, and the mechanic told me that it had air in the pump. they also diagnosed a few other things for me, which they ended up being wrong about, so I decided to go elsewhere. I went to my a friend's mechanic, who told me that I needed a new pump
  2. yes, harky, it was a reman from autozone, came with a warranty, so i think i'll be pulling it off and taking it back for a replacement. my uncle told me the same thing last night, that in 45 years of him being a mechanic, he can count on both hands how many bad pumps he's been sold that were reman. thanks for your help.
  3. I bought my 94 LS 400 in Aug. 07, so i've only had it a few months. shortly after i bought it, it began making a faint whining noise. in my experience with cars, i know this to mean it's getting low on PS fluid, so I checked it. it was fine. very quickly, the noise began to get worse, so I took it to a shop to have them listen to it, and the mechanic told me that it had air in the pump. they also diagnosed a few other things for me, which they ended up being wrong about, so I decided to go elsewhere. I went to my a friend's mechanic, who told me that I needed a new pump. So i went to the parts
×
×
  • Create New...